diff options
author | Andre McCurdy <armccurdy@gmail.com> | 2016-11-02 15:57:03 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-11-06 23:35:36 +0000 |
commit | 2295d3932cbffeca071c23e19700be8edd5e2638 (patch) | |
tree | 2807ce82d65ad5f585c254b1ed579d6ae684a8f4 /meta/recipes-devtools/gdb/gdb_7.11.1.bb | |
parent | c8669749e37fe865c197c98d5671d9de176ff4dd (diff) | |
download | poky-2295d3932cbffeca071c23e19700be8edd5e2638.tar.gz |
gdb: update 7.11+git1a982b689c -> 7.11.1
41d8236 Set GDB version number to 7.11.1.
136613e Fix PR gdb/19828: gdb -p <process from a container>: internal error
a0de87e Make gdb/linux-nat.c consider a waitstatus pending on the infrun side
cf2cd51 Add mi-threads-interrupt.exp test (PR 20039)
f0a8d0d Fix double prompt output after run control MI commands with mi-async on (PR 20045)
b5f0db4 Fix -exec-run not running asynchronously with mi-async on (PR gdb/18077)
7f8e34d Use target_terminal_ours_for_output in MI
(From OE-Core rev: 371345c0dc49bf781c27aea1e9f6a4c947fa30e6)
Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_7.11.1.bb')
-rw-r--r-- | meta/recipes-devtools/gdb/gdb_7.11.1.bb | 26 |
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.11.1.bb b/meta/recipes-devtools/gdb/gdb_7.11.1.bb new file mode 100644 index 0000000000..57cffc9983 --- /dev/null +++ b/meta/recipes-devtools/gdb/gdb_7.11.1.bb | |||
@@ -0,0 +1,26 @@ | |||
1 | require gdb.inc | ||
2 | require gdb-${PV}.inc | ||
3 | |||
4 | inherit python3-dir | ||
5 | |||
6 | EXTRA_OEMAKE_append_libc-musl = "\ | ||
7 | gt_cv_func_gnugettext1_libc=yes \ | ||
8 | gt_cv_func_gnugettext2_libc=yes \ | ||
9 | " | ||
10 | |||
11 | do_configure_prepend() { | ||
12 | if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then | ||
13 | cat > ${WORKDIR}/python << EOF | ||
14 | #!/bin/sh | ||
15 | case "\$2" in | ||
16 | --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;; | ||
17 | --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;; | ||
18 | --exec-prefix) echo "${exec_prefix}" ;; | ||
19 | *) exit 1 ;; | ||
20 | esac | ||
21 | exit 0 | ||
22 | EOF | ||
23 | chmod +x ${WORKDIR}/python | ||
24 | fi | ||
25 | } | ||
26 | CFLAGS_append_libc-musl = " -Drpl_gettimeofday=gettimeofday" | ||