summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb/gdb_10.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-10-30 22:20:58 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-02 11:35:10 +0000
commit548a9f0640f340d37add7b700f399571fde24eff (patch)
tree2270ce47535810a4b53b852392bf556d9ac68200 /meta/recipes-devtools/gdb/gdb_10.1.bb
parent4f9ef652c44a19f3575901f120402c8e88c57d13 (diff)
downloadpoky-548a9f0640f340d37add7b700f399571fde24eff.tar.gz
gdb: Update to 10.x release
here is full announcement [1] Do not add --disable-static, without adding --enable-shared because certain libraries e.g. libctf expects the default to be static which is only disabled if --enable-shared is specified Do not limit make subdirs, this is only needed when building in a unified tree, here builds are happening from a release tarball so it is redundant [1] https://www.gnu.org/software/gdb/download/ANNOUNCEMENT (From OE-Core rev: 8fb5fe5a82d173428d96ab43bab25b89ac6f25ea) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_10.1.bb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_10.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_10.1.bb b/meta/recipes-devtools/gdb/gdb_10.1.bb
new file mode 100644
index 0000000000..d70757a151
--- /dev/null
+++ b/meta/recipes-devtools/gdb/gdb_10.1.bb
@@ -0,0 +1,28 @@
1require gdb.inc
2require gdb-${PV}.inc
3
4inherit python3-dir
5
6EXTRA_OEMAKE_append_libc-musl = "\
7 gt_cv_func_gnugettext1_libc=yes \
8 gt_cv_func_gnugettext2_libc=yes \
9 gl_cv_func_working_strerror=yes \
10 gl_cv_func_strerror_0_works=yes \
11 gl_cv_func_gettimeofday_clobber=no \
12 "
13
14do_configure_prepend() {
15 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
16 cat > ${WORKDIR}/python << EOF
17#!/bin/sh
18case "\$2" in
19 --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;;
20 --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;;
21 --exec-prefix) echo "${exec_prefix}" ;;
22 *) exit 1 ;;
23esac
24exit 0
25EOF
26 chmod +x ${WORKDIR}/python
27 fi
28}