summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/libgcc_4.7.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-22 09:12:04 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-23 16:20:12 +0100
commit50170617c632e62aa68e9bbb700fd8290fa4b90e (patch)
tree9d8456a926566080693eda3ffec4a8c64b8c8238 /meta/recipes-devtools/gcc/libgcc_4.7.bb
parentb64d6af3ec80d2f4040378c785ffcac415c0827a (diff)
downloadpoky-50170617c632e62aa68e9bbb700fd8290fa4b90e.tar.gz
bitbake.conf/classes/gcc: Don't hardcode -nativesdk
Hardcoding -nativesdk as the sdk package architecture is inflexible. We may have multiple different target OS and we need a way to be able to separate them. Turning this into a configurable value allows the flexibility we need to build different SDKMACHINEs with different OS targets. The commit should have no behaviour change, just makes things more configurable. (From OE-Core rev: a2110e86b98d646e136de9ec6b8e668079b0d4f4) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gcc/libgcc_4.7.bb')
-rw-r--r--meta/recipes-devtools/gcc/libgcc_4.7.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/gcc/libgcc_4.7.bb b/meta/recipes-devtools/gcc/libgcc_4.7.bb
index 47669a210c..3b5bb43c00 100644
--- a/meta/recipes-devtools/gcc/libgcc_4.7.bb
+++ b/meta/recipes-devtools/gcc/libgcc_4.7.bb
@@ -26,7 +26,7 @@ FILES_libgcov-dev = " \
26FILES_${PN}-dbg += "${base_libdir}/.debug/" 26FILES_${PN}-dbg += "${base_libdir}/.debug/"
27 27
28do_configure () { 28do_configure () {
29 target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##` 29 target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
30 install -d ${D}${base_libdir} ${D}${libdir} 30 install -d ${D}${base_libdir} ${D}${libdir}
31 cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${B} 31 cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${B}
32 mkdir -p ${B}/${BPN} 32 mkdir -p ${B}/${BPN}
@@ -36,13 +36,13 @@ do_configure () {
36} 36}
37 37
38do_compile () { 38do_compile () {
39 target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##` 39 target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
40 cd ${B}/${BPN} 40 cd ${B}/${BPN}
41 oe_runmake MULTIBUILDTOP=${B}/$target/${BPN}/ 41 oe_runmake MULTIBUILDTOP=${B}/$target/${BPN}/
42} 42}
43 43
44do_install () { 44do_install () {
45 target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##` 45 target=`echo ${TARGET_SYS} | sed -e s#-${SDKPKGSUFFIX}##`
46 cd ${B}/${BPN} 46 cd ${B}/${BPN}
47 oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/${BPN}/ install 47 oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/${BPN}/ install
48 48