diff options
author | Dexuan Cui <dexuan.cui@intel.com> | 2011-01-15 18:47:50 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-01-17 22:04:50 +0000 |
commit | 0df3c481309e89b93e8a57773eb9c470b4dd13a7 (patch) | |
tree | d8f0bbaa5672dee61273d5502546409034d0a5d8 /meta/recipes-devtools/gcc/libgcc_4.5.1.bb | |
parent | 2ce2c1e6f9c5196c4346c3839bf594dd821c20ee (diff) | |
download | poky-0df3c481309e89b93e8a57773eb9c470b4dd13a7.tar.gz |
libgcc: use the new recipe (rather than gcc-runtime) to install libgcc_s.so* and crt*.o
Currently gcc-runtime installs the files, but actually gcc-runtime's
do_configure checks if the files are available, so before we build gcc-runtime,
we should have some recipe install the files first! -- currently
gcc-cross-intermediate actually does that(gcc-cross also installs the files,
but it installs into the gcc-build-internal* directory), but
gcc-cross-intermediate will have its own sysroot in future, after that,
gcc-runtime won't build. So let us add this new target recipe and move the
installation of the files from gcc-runtime into it.
Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Diffstat (limited to 'meta/recipes-devtools/gcc/libgcc_4.5.1.bb')
-rw-r--r-- | meta/recipes-devtools/gcc/libgcc_4.5.1.bb | 42 |
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/libgcc_4.5.1.bb b/meta/recipes-devtools/gcc/libgcc_4.5.1.bb new file mode 100644 index 0000000000..a99fdeffd4 --- /dev/null +++ b/meta/recipes-devtools/gcc/libgcc_4.5.1.bb | |||
@@ -0,0 +1,42 @@ | |||
1 | require gcc-${PV}.inc | ||
2 | |||
3 | PR = "r0" | ||
4 | |||
5 | INHIBIT_DEFAULT_DEPS = "1" | ||
6 | DEPENDS = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++" | ||
7 | |||
8 | PACKAGES = "\ | ||
9 | ${PN} \ | ||
10 | ${PN}-dev \ | ||
11 | " | ||
12 | |||
13 | FILES_${PN} = "${base_libdir}/libgcc*.so.*" | ||
14 | FILES_${PN}-dev = " \ | ||
15 | ${base_libdir}/libgcc*.so \ | ||
16 | ${libdir}/${TARGET_SYS}/${BINV}/crt* \ | ||
17 | ${libdir}/${TARGET_SYS}/${BINV}/libgcc*" | ||
18 | |||
19 | do_fetch[noexec] = "1" | ||
20 | do_unpack[noexec] = "1" | ||
21 | do_patch[noexec] = "1" | ||
22 | do_configure[noexec] = "1" | ||
23 | do_compile[noexec] = "1" | ||
24 | |||
25 | do_install () { | ||
26 | target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##` | ||
27 | |||
28 | # Install libgcc from our gcc-cross saved data | ||
29 | install -d ${D}${base_libdir} ${D}${libdir} | ||
30 | cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${D} | ||
31 | |||
32 | # Move libgcc_s into /lib | ||
33 | mkdir -p ${D}${base_libdir} | ||
34 | if [ -f ${D}${libdir}/nof/libgcc_s.so ]; then | ||
35 | mv ${D}${libdir}/nof/libgcc* ${D}${base_libdir} | ||
36 | else | ||
37 | mv ${D}${libdir}/libgcc* ${D}${base_libdir} || true | ||
38 | fi | ||
39 | } | ||
40 | |||
41 | BBCLASSEXTEND = "nativesdk" | ||
42 | |||