summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/libgcc_4.5.1.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-31 16:37:32 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-31 16:37:32 +0000
commit21f2dae46b481dbf34f6874ae814dcd23fc86d54 (patch)
tree925cbfe22d97fa3158a6af5ec79ceb876f69ec28 /meta/recipes-devtools/gcc/libgcc_4.5.1.bb
parent0e70557c92d02a024fd6028d3f0530f3ece979e0 (diff)
downloadpoky-21f2dae46b481dbf34f6874ae814dcd23fc86d54.tar.gz
libgcc: Explicitly wait for the libc packaging to occur before libgcc packages
libgcc can link against the libc and libc can be dynamically renamed so we ensure we package after libc. There was code in the gcc core for this in the ipk case but it wasn't moved as part of the libgcc split, this change fixes that oversight. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gcc/libgcc_4.5.1.bb')
-rw-r--r--meta/recipes-devtools/gcc/libgcc_4.5.1.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/libgcc_4.5.1.bb b/meta/recipes-devtools/gcc/libgcc_4.5.1.bb
index a99fdeffd4..b6cf2685e5 100644
--- a/meta/recipes-devtools/gcc/libgcc_4.5.1.bb
+++ b/meta/recipes-devtools/gcc/libgcc_4.5.1.bb
@@ -38,5 +38,9 @@ do_install () {
38 fi 38 fi
39} 39}
40 40
41do_package_write_ipk[depends] += "virtual/libc:do_package"
42do_package_write_deb[depends] += "virtual/libc:do_package"
43do_package_write_rpm[depends] += "virtual/libc:do_package"
44
41BBCLASSEXTEND = "nativesdk" 45BBCLASSEXTEND = "nativesdk"
42 46