summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/gcc_6.4.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-10-14 08:48:57 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-14 07:55:54 -0700
commit49b2fafe0af19d41d5ab9bb1e8a8194258e3e92d (patch)
treebe8ae458684a2e3a72bed089d129bd5d679a9613 /meta/recipes-devtools/gcc/gcc_6.4.bb
parentdb0b3dbc3db1ebdc181cabb758958e501eef2367 (diff)
downloadpoky-49b2fafe0af19d41d5ab9bb1e8a8194258e3e92d.tar.gz
gcc6: Upgrade to 6.4
(From OE-Core rev: 02d2a14333b3cbc8e6acf74245f3db6b6b94c91b) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> (cherry picked from commit 7874fa86cb583fe6a178b95ead09430486197197) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc_6.4.bb')
-rw-r--r--meta/recipes-devtools/gcc/gcc_6.4.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc_6.4.bb b/meta/recipes-devtools/gcc/gcc_6.4.bb
new file mode 100644
index 0000000000..b0a523cae2
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc_6.4.bb
@@ -0,0 +1,15 @@
1require recipes-devtools/gcc/gcc-${PV}.inc
2require gcc-target.inc
3
4# Building with thumb enabled on armv4t fails with
5# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs
6# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output
7ARM_INSTRUCTION_SET_armv4 = "arm"
8
9do_configure_prepend() {
10 # Easiest way to stop bad RPATHs getting into the library since we have a
11 # broken libtool here
12 sed -i -e 's/hardcode_into_libs=yes/hardcode_into_libs=no/' ${S}/libcc1/configure
13}
14
15BBCLASSEXTEND = "nativesdk"