summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/gcc_6.3.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-12-21 12:08:31 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-09 13:39:12 +0000
commitde1a1cf76e22246bc772f584142e0de357f196eb (patch)
tree634fbd2c4d41c19756540b9faa85c10be9eaebaa /meta/recipes-devtools/gcc/gcc_6.3.bb
parentcfa8b1ed6fb20d7a4a80b9b938e1810ac450da51 (diff)
downloadpoky-de1a1cf76e22246bc772f584142e0de357f196eb.tar.gz
gcc6: Upgrade to 6.3.0
6.3.0 is a bugfix release in gcc 6 series (From OE-Core rev: 36ffcd1d7d2ab9dcc91e9c09623a6613a248bc69) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc_6.3.bb')
-rw-r--r--meta/recipes-devtools/gcc/gcc_6.3.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc_6.3.bb b/meta/recipes-devtools/gcc/gcc_6.3.bb
new file mode 100644
index 0000000000..b0a523cae2
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc_6.3.bb
@@ -0,0 +1,15 @@
1require recipes-devtools/gcc/gcc-${PV}.inc
2require gcc-target.inc
3
4# Building with thumb enabled on armv4t fails with
5# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs
6# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output
7ARM_INSTRUCTION_SET_armv4 = "arm"
8
9do_configure_prepend() {
10 # Easiest way to stop bad RPATHs getting into the library since we have a
11 # broken libtool here
12 sed -i -e 's/hardcode_into_libs=yes/hardcode_into_libs=no/' ${S}/libcc1/configure
13}
14
15BBCLASSEXTEND = "nativesdk"