diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-07-28 14:23:37 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-07-31 10:32:37 +0100 |
commit | dab511c36dc455d3ada0c058e20ac42c71e3c8b7 (patch) | |
tree | 0bd73809bebdaab8fa42c8024bfd594de3bb8b9f /meta/recipes-devtools/gcc/gcc_4.9.bb | |
parent | 3b7c38458856805588d552508de10944ed38d9f2 (diff) | |
download | poky-dab511c36dc455d3ada0c058e20ac42c71e3c8b7.tar.gz |
gcc: Add support for nativesdk-gcc
Being able to build a nativesdk gcc is useful, particularly in cases
where the host compiler may be of an incompatible version (or a 32
bit compiler is needed).
Sadly, building nativesdk-gcc is not straight forward. We install
nativesdk-gcc into a relocatable location and this means that its
library locations can change. "Normal" sysroot support doesn't help
in this case since the values of paths like "libdir" change, not just
base root directory of the system.
In order to handle this we do two things:
a) Add %r into spec file markup which can be used for injected paths
such as SYSTEMLIBS_DIR (see gcc_multilib_setup()).
b) Add other paths which need relocation into a .gccrelocprefix section
which the relocation code will notice and adjust automatically.
This patch adds tweaks to the relocation script to handle the
new section too.
(From OE-Core rev: cd3d874fced2ee4c950d9964d30c0588fd8772e7)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc_4.9.bb')
-rw-r--r-- | meta/recipes-devtools/gcc/gcc_4.9.bb | 7 |
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc_4.9.bb b/meta/recipes-devtools/gcc/gcc_4.9.bb index c4827c6443..b84baae6da 100644 --- a/meta/recipes-devtools/gcc/gcc_4.9.bb +++ b/meta/recipes-devtools/gcc/gcc_4.9.bb | |||
@@ -5,3 +5,10 @@ require gcc-target.inc | |||
5 | # | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs | 5 | # | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs |
6 | # | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output | 6 | # | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output |
7 | ARM_INSTRUCTION_SET_armv4 = "arm" | 7 | ARM_INSTRUCTION_SET_armv4 = "arm" |
8 | |||
9 | BBCLASSEXTEND = "nativesdk" | ||
10 | |||
11 | #SYSTEMHEADERS_class-nativesdk = "${@'${target_includedir}'.replace(d.getVar('SDKPATH', True),'%r')}" | ||
12 | #SYSTEMLIBS_class-nativesdk = "${@'${target_base_libdir}'.replace(d.getVar('SDKPATH', True),'%r')}/" | ||
13 | #SYSTEMLIBS1_class-nativesdk = "${@'${target_libdir}'.replace(d.getVar('SDKPATH', True),'%r')}/" | ||
14 | |||