summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/gcc_10.3.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-04-09 12:46:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-04-18 11:37:24 +0100
commite237e345fbb640e6123d3c70f9c92002758f7910 (patch)
tree200ae2dc2d2cf841be94874d216af91cbf04e8df /meta/recipes-devtools/gcc/gcc_10.3.bb
parentb50e51b1c848e0162e693e986be59c15e5e57e5c (diff)
downloadpoky-e237e345fbb640e6123d3c70f9c92002758f7910.tar.gz
gcc: Upgrade to 10.3.0 bug-fix release
Drop aarch64 backports which are already upstream List of bugs fixed is [1] [1] https://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=RESOLVED&list_id=298084&resolution=FIXED&target_milestone=10.3 (From OE-Core rev: 023806e0e0de2b0e814e6e38d78bf2faa9661f19) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc_10.3.bb')
-rw-r--r--meta/recipes-devtools/gcc/gcc_10.3.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc_10.3.bb b/meta/recipes-devtools/gcc/gcc_10.3.bb
new file mode 100644
index 0000000000..7d93590588
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc_10.3.bb
@@ -0,0 +1,14 @@
1require recipes-devtools/gcc/gcc-${PV}.inc
2require gcc-target.inc
3
4# Building with thumb enabled on armv4t armv5t fails with
5# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs
6# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output
7ARM_INSTRUCTION_SET_armv4 = "arm"
8ARM_INSTRUCTION_SET_armv5 = "arm"
9
10ARMFPARCHEXT_armv6 = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
11ARMFPARCHEXT_armv7a = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
12ARMFPARCHEXT_armv7ve = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
13
14BBCLASSEXTEND = "nativesdk"