summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/gcc-runtime_8.3.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-08-13 08:28:35 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-14 17:33:49 +0100
commit1dc2823d62b253a6f7d05f71426f77925523de49 (patch)
tree8210045bbff9ac6dab6021a4c0bf93743d2df59f /meta/recipes-devtools/gcc/gcc-runtime_8.3.bb
parente64e8aa72544c1eb271411a0a3c33c9d4f5b606c (diff)
downloadpoky-1dc2823d62b253a6f7d05f71426f77925523de49.tar.gz
gcc-runtime: Move content from gcclibdir into libdir
OE does not use the traditional /usr/lib/gcc prefix to store gcc-runtime it basically is moved into libdir, however some newer files were installed by newer versions of gcc especially libgomp ( omp.h openacc.h ) into gcclibdir, so we have content in both directories, this confuses other tools which are trying to guess the gcc installation and its runtime location, since now we have two directories, the tools either choose one or other and we get inconsistent behavior, e.g. clang for aarch64 uses /usr/lib but same clang for riscv64 chose /usr/lib/gcc This change ensures that OE ends up with single valid location for gcc runtime files Move more common bits into common inc file (From OE-Core rev: e9e5744ba8b0d43c8b874d365f83071ce20bf0a1) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc-runtime_8.3.bb')
-rw-r--r--meta/recipes-devtools/gcc/gcc-runtime_8.3.bb10
1 files changed, 0 insertions, 10 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-runtime_8.3.bb b/meta/recipes-devtools/gcc/gcc-runtime_8.3.bb
index a1c7a76d0b..dd430b57eb 100644
--- a/meta/recipes-devtools/gcc/gcc-runtime_8.3.bb
+++ b/meta/recipes-devtools/gcc/gcc-runtime_8.3.bb
@@ -1,12 +1,2 @@
1require recipes-devtools/gcc/gcc-${PV}.inc 1require recipes-devtools/gcc/gcc-${PV}.inc
2require gcc-runtime.inc 2require gcc-runtime.inc
3
4# Disable ifuncs for libatomic on arm conflicts -march/-mcpu
5EXTRA_OECONF_append_arm = " libat_cv_have_ifunc=no "
6
7FILES_libgomp-dev += "\
8 ${libdir}/gcc/${TARGET_SYS}/${BINV}/include/openacc.h \
9"
10
11# Building with thumb enabled on armv6t fails
12ARM_INSTRUCTION_SET_armv6 = "arm"