summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/gcc-cross-canadian_4.5.1.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-11-08 08:30:41 -0800
committerSaul Wold <Saul.Wold@intel.com>2010-11-18 13:30:25 -0800
commitb1dd356f5eab11fa6fc18013189e51c13fdd763b (patch)
treea1c8e13223ea108b88507c35dfdf0c1b9d6f1edb /meta/recipes-devtools/gcc/gcc-cross-canadian_4.5.1.bb
parentcaf8fe37496f49ed920036ac8763ec56b0029570 (diff)
downloadpoky-b1dd356f5eab11fa6fc18013189e51c13fdd763b.tar.gz
gcc: upgrade from 4.5.0 to 4.5.1
Removed these patches which are not needed anymore. gcc-4.5.0_to_svn_162697.patch.bz2 : All the commits in this patch is part of the 4.5.1 branch. So moving to 4.5.1 makes this patch obsolete gcc_revert_base_version_to_4.5.0.patch: moving to 4.5.1 removes need of this patch gcc-pr43698-arm-rev-instr.patch: upstream has this fix. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc-cross-canadian_4.5.1.bb')
-rw-r--r--meta/recipes-devtools/gcc/gcc-cross-canadian_4.5.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-cross-canadian_4.5.1.bb b/meta/recipes-devtools/gcc/gcc-cross-canadian_4.5.1.bb
new file mode 100644
index 0000000000..e160aab8a2
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc-cross-canadian_4.5.1.bb
@@ -0,0 +1,25 @@
1inherit cross-canadian
2
3require gcc-${PV}.inc
4require gcc-cross-canadian.inc
5require gcc-configure-sdk.inc
6require gcc-package-sdk.inc
7
8PR = "r0"
9
10DEPENDS += "gmp-nativesdk mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
11RDEPENDS_${PN} += "mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
12
13SYSTEMHEADERS = "/usr/include"
14SYSTEMLIBS = "/lib/"
15SYSTEMLIBS1 = "/usr/lib/"
16
17EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
18 --disable-libgomp --disable-libmudflap \
19 --with-mpfr=${STAGING_DIR_HOST}${layout_exec_prefix} \
20 --with-mpc=${STAGING_DIR_HOST}${layout_exec_prefix}"
21
22# to find libmpfr
23# export LD_LIBRARY_PATH = "{STAGING_DIR_HOST}${layout_exec_prefix}"
24
25PARALLEL_MAKE = ""