diff options
author | Ross Burton <ross.burton@intel.com> | 2017-01-09 15:28:10 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-01-16 18:05:12 +0000 |
commit | 2bc83c8a3b87f29b62fe778ca1e8790604b72d5f (patch) | |
tree | b039a8eaab42f83815f8f175bfab61e9895902df /meta/recipes-devtools/flex/flex_2.6.0.bb | |
parent | 171a07091873b5692f74751edc3ae09172ae3d76 (diff) | |
download | poky-2bc83c8a3b87f29b62fe778ca1e8790604b72d5f.tar.gz |
flex: upgrade to 2.6.2
Patches dropped as they are merged upstream:
- CVE-2016-6354.patch
- 0002-avoid-c-comments-in-c-code-fails-with-gcc-6.patch
- do_not_create_pdf_doc.patch
Apply a patch from github to simplify cross-compilation and not need a
flex-native to bootstrap.
(From OE-Core rev: 3632abd01abb8dfff230e18f828af705da488f97)
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/flex/flex_2.6.0.bb')
-rw-r--r-- | meta/recipes-devtools/flex/flex_2.6.0.bb | 62 |
1 files changed, 0 insertions, 62 deletions
diff --git a/meta/recipes-devtools/flex/flex_2.6.0.bb b/meta/recipes-devtools/flex/flex_2.6.0.bb deleted file mode 100644 index ab35b09f99..0000000000 --- a/meta/recipes-devtools/flex/flex_2.6.0.bb +++ /dev/null | |||
@@ -1,62 +0,0 @@ | |||
1 | SUMMARY = "Flex (The Fast Lexical Analyzer)" | ||
2 | DESCRIPTION = "Flex is a fast lexical analyser generator. Flex is a tool for generating programs that recognize \ | ||
3 | lexical patterns in text." | ||
4 | HOMEPAGE = "http://sourceforge.net/projects/flex/" | ||
5 | SECTION = "devel" | ||
6 | LICENSE = "BSD" | ||
7 | |||
8 | DEPENDS = "${@bb.utils.contains('PTEST_ENABLED', '1', 'bison-native flex-native', '', d)}" | ||
9 | BBCLASSEXTEND = "native nativesdk" | ||
10 | |||
11 | LIC_FILES_CHKSUM = "file://COPYING;md5=e4742cf92e89040b39486a6219b68067" | ||
12 | |||
13 | SRC_URI = "${SOURCEFORGE_MIRROR}/flex/flex-${PV}.tar.bz2 \ | ||
14 | file://run-ptest \ | ||
15 | file://do_not_create_pdf_doc.patch \ | ||
16 | file://0001-tests-add-a-target-for-building-tests-without-runnin.patch \ | ||
17 | file://0002-avoid-c-comments-in-c-code-fails-with-gcc-6.patch \ | ||
18 | file://CVE-2016-6354.patch \ | ||
19 | ${@bb.utils.contains('PTEST_ENABLED', '1', '', 'file://disable-tests.patch', d)} \ | ||
20 | " | ||
21 | |||
22 | SRC_URI[md5sum] = "266270f13c48ed043d95648075084d59" | ||
23 | SRC_URI[sha256sum] = "24e611ef5a4703a191012f80c1027dc9d12555183ce0ecd46f3636e587e9b8e9" | ||
24 | |||
25 | # Flex has moved to github from 2.6.1 onwards | ||
26 | UPSTREAM_CHECK_URI = "https://github.com/westes/flex/releases" | ||
27 | UPSTREAM_CHECK_REGEX = "flex-(?P<pver>\d+(\.\d+)+)\.tar" | ||
28 | |||
29 | inherit autotools gettext texinfo ptest | ||
30 | |||
31 | M4 = "${bindir}/m4" | ||
32 | M4_class-native = "${STAGING_BINDIR_NATIVE}/m4" | ||
33 | EXTRA_OECONF += "ac_cv_path_M4=${M4}" | ||
34 | EXTRA_OEMAKE += "m4=${STAGING_BINDIR_NATIVE}/m4" | ||
35 | |||
36 | EXTRA_OEMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', 'FLEX=${STAGING_BINDIR_NATIVE}/flex', '', d)}" | ||
37 | |||
38 | do_install_append_class-native() { | ||
39 | create_wrapper ${D}/${bindir}/flex M4=${M4} | ||
40 | } | ||
41 | |||
42 | do_install_append_class-nativesdk() { | ||
43 | create_wrapper ${D}/${bindir}/flex M4=${M4} | ||
44 | } | ||
45 | |||
46 | RDEPENDS_${PN} += "m4" | ||
47 | RDEPENDS_${PN}-ptest += "bash gawk" | ||
48 | |||
49 | do_compile_ptest() { | ||
50 | oe_runmake -C ${B}/tests -f ${B}/tests/Makefile top_builddir=${B} INCLUDES=-I${S}/src buildtests | ||
51 | } | ||
52 | |||
53 | do_install_ptest() { | ||
54 | mkdir -p ${D}${PTEST_PATH}/build-aux/ | ||
55 | cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/ | ||
56 | cp -r ${S}/tests/* ${D}${PTEST_PATH} | ||
57 | cp -r ${B}/tests/* ${D}${PTEST_PATH} | ||
58 | sed -e 's/^Makefile:/_Makefile:/' \ | ||
59 | -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' \ | ||
60 | -e 's/^builddir = \(.*\)/builddir = ./' -e 's/^top_builddir = \(.*\)/top_builddir = ./' \ | ||
61 | -i ${D}${PTEST_PATH}/Makefile | ||
62 | } | ||