summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/flex/flex_2.6.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-15 13:59:34 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-22 16:08:51 +0000
commit86c8b8b82e39ca4233ef0ae258dc0cb18734151c (patch)
treed47c506f3f0719e5818349f3fecfd5a34144ba2f /meta/recipes-devtools/flex/flex_2.6.0.bb
parentdad130b76493429b6dc1de436cb758cd1735f808 (diff)
downloadpoky-86c8b8b82e39ca4233ef0ae258dc0cb18734151c.tar.gz
flex: update to 2.6.0
Drop backported 0001-bison-test-fixes-Do-not-use-obsolete-bison-construct.patch Test cases have been completely rearranged upstream, so ptest support is fully rewritten. Merge split bb/inc as there's no other user of the .inc [RB] As automake insists adding BUILD_SOURCES as a dependency to the "all" target, remove tests/ from the build unless ptests are enabled. This means native builds don't need a bison dependency. If ptests are enabled, we build-depend on flex-native and bison-native for the test suite, and tell it to use the flex-native binary instead of attempting to run the cross flex it just built. [RB] Move in-tree files from files/ to flex/ for consistency. [RB] (From OE-Core rev: 4fe048b7b32eb3d20a43171b83e8ad2037192d34) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/flex/flex_2.6.0.bb')
-rw-r--r--meta/recipes-devtools/flex/flex_2.6.0.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-devtools/flex/flex_2.6.0.bb b/meta/recipes-devtools/flex/flex_2.6.0.bb
new file mode 100644
index 0000000000..8285426d45
--- /dev/null
+++ b/meta/recipes-devtools/flex/flex_2.6.0.bb
@@ -0,0 +1,55 @@
1SUMMARY = "Flex (The Fast Lexical Analyzer)"
2DESCRIPTION = "Flex is a fast lexical analyser generator. Flex is a tool for generating programs that recognize \
3lexical patterns in text."
4HOMEPAGE = "http://sourceforge.net/projects/flex/"
5SECTION = "devel"
6LICENSE = "BSD"
7
8DEPENDS = "${@bb.utils.contains('PTEST_ENABLED', '1', 'bison-native flex-native', '', d)}"
9BBCLASSEXTEND = "native nativesdk"
10
11LIC_FILES_CHKSUM = "file://COPYING;md5=e4742cf92e89040b39486a6219b68067"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/flex/flex-${PV}.tar.bz2 \
14 file://run-ptest \
15 file://do_not_create_pdf_doc.patch \
16 file://0001-tests-add-a-target-for-building-tests-without-runnin.patch \
17 ${@bb.utils.contains('PTEST_ENABLED', '1', '', 'file://disable-tests.patch', d)} \
18 "
19
20SRC_URI[md5sum] = "266270f13c48ed043d95648075084d59"
21SRC_URI[sha256sum] = "24e611ef5a4703a191012f80c1027dc9d12555183ce0ecd46f3636e587e9b8e9"
22
23UPSTREAM_CHECK_REGEX = "flex-(?P<pver>\d+(\.\d+)+)\.tar"
24
25inherit autotools gettext texinfo ptest
26
27M4 = "${bindir}/m4"
28M4_class-native = "${STAGING_BINDIR_NATIVE}/m4"
29EXTRA_OECONF += "ac_cv_path_M4=${M4}"
30EXTRA_OEMAKE += "m4=${STAGING_BINDIR_NATIVE}/m4"
31
32EXTRA_OEMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', 'FLEX=${STAGING_BINDIR_NATIVE}/flex', '', d)}"
33
34do_install_append_class-native() {
35 create_wrapper ${D}/${bindir}/flex M4=${M4}
36}
37
38do_install_append_class-nativesdk() {
39 create_wrapper ${D}/${bindir}/flex M4=${M4}
40}
41
42RDEPENDS_${PN} += "m4"
43RDEPENDS_${PN}-ptest += "bash gawk"
44
45do_compile_ptest() {
46 oe_runmake -C ${B}/tests -f ${B}/tests/Makefile top_builddir=${B} INCLUDES=-I${S}/src buildtests
47}
48
49do_install_ptest() {
50 mkdir -p ${D}${PTEST_PATH}/build-aux/
51 cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
52 cp -r ${S}/tests/* ${D}${PTEST_PATH}
53 cp -r ${B}/tests/* ${D}${PTEST_PATH}
54 sed -e 's/^Makefile:/_Makefile:/' -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' -i ${D}${PTEST_PATH}/Makefile
55}