summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.32.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2017-11-14 01:58:44 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-21 13:06:12 +0000
commit1b6f9d370b5eb17b1ee633077041bb9cba1254f1 (patch)
treefabc1769bc551986e3eea218bbd198148ee75f2a /meta/recipes-devtools/file/file_5.32.bb
parent6dfc03cf472069215e8bad0274a9048e0a183d1d (diff)
downloadpoky-1b6f9d370b5eb17b1ee633077041bb9cba1254f1.tar.gz
file: 5.31 -> 5.32
Rebase debian-742262.patch for new source. (From OE-Core rev: 4231e238d9fe6b2178b900cde49ca17ce5aa1f47) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/file/file_5.32.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.32.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.32.bb b/meta/recipes-devtools/file/file_5.32.bb
new file mode 100644
index 0000000000..5e15925126
--- /dev/null
+++ b/meta/recipes-devtools/file/file_5.32.bb
@@ -0,0 +1,48 @@
1SUMMARY = "File classification tool"
2DESCRIPTION = "File attempts to classify files depending \
3on their contents and prints a description if a match is found."
4HOMEPAGE = "http://www.darwinsys.com/file/"
5SECTION = "console/utils"
6
7# two clause BSD
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188"
10
11DEPENDS = "zlib file-replacement-native"
12DEPENDS_class-native = "zlib-native"
13
14# Blacklist a bogus tag in upstream check
15UPSTREAM_CHECK_GITTAGREGEX = "FILE(?P<pver>(?!6_23).+)"
16
17SRC_URI = "git://github.com/file/file.git \
18 file://debian-742262.patch \
19 file://0001-Add-P-prompt-into-Usage-info.patch \
20 "
21
22SRCREV = "d474e35513940dbca039b510b4de705b44f5bd9c"
23S = "${WORKDIR}/git"
24
25inherit autotools
26
27EXTRA_OEMAKE_append_class-target = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
28EXTRA_OEMAKE_append_class-nativesdk = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
29
30CFLAGS_append = " -std=c99"
31
32FILES_${PN} += "${datadir}/misc/*.mgc"
33
34do_install_append_class-native() {
35 create_cmdline_wrapper ${D}/${bindir}/file \
36 --magic-file ${datadir}/misc/magic.mgc
37}
38
39do_install_append_class-nativesdk() {
40 create_cmdline_wrapper ${D}/${bindir}/file \
41 --magic-file ${datadir}/misc/magic.mgc
42}
43
44BBCLASSEXTEND = "native nativesdk"
45PROVIDES_append_class-native = " file-replacement-native"
46# Don't use NATIVE_PACKAGE_PATH_SUFFIX as that hides libmagic from anyone who
47# depends on file-replacement-native.
48bindir_append_class-native = "/file-native"