summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.31.bb
diff options
context:
space:
mode:
authorFan Xin <fan.xin@jp.fujitsu.com>2017-06-20 13:53:06 +0900
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-28 15:52:18 +0100
commit3674b6e8bde8703f357913f2336e5fad4c8fc276 (patch)
tree313c991cda4eb46685d4fd32f0083b506b696e34 /meta/recipes-devtools/file/file_5.31.bb
parentd620f8c243da38f46b1340839472a17faf843ac8 (diff)
downloadpoky-3674b6e8bde8703f357913f2336e5fad4c8fc276.tar.gz
file: 5.30 -> 5.31
1. Upgrade file from 5.30 to 5.31 2. Rebase the following patch file. debian-742262.patch (From OE-Core rev: f38290ec2a727427a6481e4dafb02ecd8a60fad1) Signed-off-by: Fan Xin <fan.xin@jp.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/file/file_5.31.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.31.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.31.bb b/meta/recipes-devtools/file/file_5.31.bb
new file mode 100644
index 0000000000..1b1f50284f
--- /dev/null
+++ b/meta/recipes-devtools/file/file_5.31.bb
@@ -0,0 +1,48 @@
1SUMMARY = "File classification tool"
2DESCRIPTION = "File attempts to classify files depending \
3on their contents and prints a description if a match is found."
4HOMEPAGE = "http://www.darwinsys.com/file/"
5SECTION = "console/utils"
6
7# two clause BSD
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188"
10
11DEPENDS = "zlib file-replacement-native"
12DEPENDS_class-native = "zlib-native"
13
14# Blacklist a bogus tag in upstream check
15UPSTREAM_CHECK_GITTAGREGEX = "FILE(?P<pver>(?!6_23).+)"
16
17SRC_URI = "git://github.com/file/file.git \
18 file://debian-742262.patch \
19 file://0001-Add-P-prompt-into-Usage-info.patch \
20 "
21
22SRCREV = "70c5f15060c7ad81150177de83a3e64500a54c9f"
23S = "${WORKDIR}/git"
24
25inherit autotools
26
27EXTRA_OEMAKE_append_class-target = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
28EXTRA_OEMAKE_append_class-nativesdk = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
29
30CFLAGS_append = " -std=c99"
31
32FILES_${PN} += "${datadir}/misc/*.mgc"
33
34do_install_append_class-native() {
35 create_cmdline_wrapper ${D}/${bindir}/file \
36 --magic-file ${datadir}/misc/magic.mgc
37}
38
39do_install_append_class-nativesdk() {
40 create_cmdline_wrapper ${D}/${bindir}/file \
41 --magic-file ${datadir}/misc/magic.mgc
42}
43
44BBCLASSEXTEND = "native nativesdk"
45PROVIDES_append_class-native = " file-replacement-native"
46# Don't use NATIVE_PACKAGE_PATH_SUFFIX as that hides libmagic from anyone who
47# depends on file-replacement-native.
48bindir_append_class-native = "/file-native"