summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.22.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-01-07 07:02:05 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-08 09:24:49 +0000
commit9a998a4e6581e0b528a52561bb2501ae8504b2cf (patch)
treeed4a7d932cad50b9d9fb9b98485d58875f98a69c /meta/recipes-devtools/file/file_5.22.bb
parent19399d5d291fd1796e174439e01e39b9197cb614 (diff)
downloadpoky-9a998a4e6581e0b528a52561bb2501ae8504b2cf.tar.gz
file: upgrade to 5.22
(From OE-Core rev: fa81c9fd14067075afbfe7787a3114b96abb902a) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/file/file_5.22.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.22.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.22.bb b/meta/recipes-devtools/file/file_5.22.bb
new file mode 100644
index 0000000000..9c6bb38d71
--- /dev/null
+++ b/meta/recipes-devtools/file/file_5.22.bb
@@ -0,0 +1,35 @@
1SUMMARY = "File classification tool"
2DESCRIPTION = "File attempts to classify files depending \
3on their contents and prints a description if a match is found."
4HOMEPAGE = "http://www.darwinsys.com/file/"
5SECTION = "console/utils"
6
7# two clause BSD
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188"
10
11DEPENDS = "zlib file-native"
12DEPENDS_class-native = "zlib-native"
13
14SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
15 file://debian-742262.patch \
16 "
17
18SRC_URI[md5sum] = "8fb13e5259fe447e02c4a37bc7225add"
19SRC_URI[sha256sum] = "c4e3a8e44cb888c5e4b476e738503e37fb9de3b25a38c143e214bfc12109fc0b"
20
21inherit autotools
22
23FILES_${PN} += "${datadir}/misc/*.mgc"
24
25do_install_append_class-native() {
26 create_cmdline_wrapper ${D}/${bindir}/file \
27 --magic-file ${datadir}/misc/magic.mgc
28}
29
30do_install_append_class-nativesdk() {
31 create_cmdline_wrapper ${D}/${bindir}/file \
32 --magic-file ${datadir}/misc/magic.mgc
33}
34
35BBCLASSEXTEND = "native nativesdk"