summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.16.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-devtools/file/file_5.16.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-devtools/file/file_5.16.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.16.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.16.bb b/meta/recipes-devtools/file/file_5.16.bb
new file mode 100644
index 0000000000..46dbf88f8d
--- /dev/null
+++ b/meta/recipes-devtools/file/file_5.16.bb
@@ -0,0 +1,36 @@
1SUMMARY = "File classification tool"
2DESCRIPTION = "File attempts to classify files depending \
3on their contents and prints a description if a match is found."
4HOMEPAGE = "http://www.darwinsys.com/file/"
5SECTION = "console/utils"
6
7# two clause BSD
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188"
10
11DEPENDS = "zlib file-native"
12DEPENDS_class-native = "zlib-native"
13
14SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
15 file://dump \
16 file://filesystems"
17
18SRC_URI[md5sum] = "359c0cf41c3d438d17b4d293f3b950dc"
19SRC_URI[sha256sum] = "48bcac7726c37a8a0bc7ffa16b58993575657dd7b382039380fb3b74ab389261"
20
21inherit autotools
22
23do_configure_prepend() {
24 cp ${WORKDIR}/dump ${S}/magic/Magdir/
25 cp ${WORKDIR}/filesystems ${S}/magic/Magdir/
26}
27
28FILES_${PN} += "${datadir}/misc/*.mgc"
29
30do_install_append_class-native() {
31 create_cmdline_wrapper ${D}/${bindir}/file \
32 --magic-file ${datadir}/misc/magic.mgc
33}
34
35
36BBCLASSEXTEND = "native nativesdk"