summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.13.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2013-02-25 10:39:44 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-28 23:15:51 +0000
commitef6e4e98df6b78fbe4738402bec0325c29186494 (patch)
tree27018bf12880ea9dc0475ad845f4c74b98c7e73c /meta/recipes-devtools/file/file_5.13.bb
parentbaa357ee206515004ed2da6b1b09836d96a844cd (diff)
downloadpoky-ef6e4e98df6b78fbe4738402bec0325c29186494.tar.gz
file: Update to 5.13
(From OE-Core rev: c865e471fc88984b8e712c0df8f45dc9a30619fb) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/file/file_5.13.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.13.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.13.bb b/meta/recipes-devtools/file/file_5.13.bb
new file mode 100644
index 0000000000..c97fed4d97
--- /dev/null
+++ b/meta/recipes-devtools/file/file_5.13.bb
@@ -0,0 +1,38 @@
1SUMMARY = "File classification tool"
2DESCRIPTION = "File attempts to classify files depending \
3on their contents and prints a description if a match is found."
4HOMEPAGE = "http://www.darwinsys.com/file/"
5SECTION = "console/utils"
6
7# two clause BSD
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188"
10
11DEPENDS = "zlib file-native"
12DEPENDS_class-native = "zlib-native"
13PR = "r0"
14
15SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
16 file://fix_version_check.patch \
17 file://dump \
18 file://filesystems"
19
20SRC_URI[md5sum] = "d60c1364ba956eff7d21f8250808fc6d"
21SRC_URI[sha256sum] = "f75b7b23ac576b47ed4ba4915e2fb239d9c0d74ac5b4e6a89704b1ed45ee6e2b"
22
23inherit autotools
24
25do_configure_prepend() {
26 cp ${WORKDIR}/dump ${S}/magic/Magdir/
27 cp ${WORKDIR}/filesystems ${S}/magic/Magdir/
28}
29
30FILES_${PN} += "${datadir}/misc/*.mgc"
31
32do_install_append_class-native() {
33 create_cmdline_wrapper ${D}/${bindir}/file \
34 --magic-file ${datadir}/misc/magic.mgc
35}
36
37
38BBCLASSEXTEND = "native"