summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/fdisk/gptfdisk_1.0.4.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2018-09-06 12:29:24 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-10 12:13:06 +0100
commitd9149d7cc951fdbea0f0f4d603198bc62fe17de1 (patch)
treeead9416bdfad98e485d0325608e02141c31415b2 /meta/recipes-devtools/fdisk/gptfdisk_1.0.4.bb
parent74dacabf15c98a64ee85220c1d8364a7de061ff1 (diff)
downloadpoky-d9149d7cc951fdbea0f0f4d603198bc62fe17de1.tar.gz
gptfdisk: update to 1.0.4
(From OE-Core rev: 20a2a6cb344f7f4c527f8e44f8da8b9e0e7bd780) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/fdisk/gptfdisk_1.0.4.bb')
-rw-r--r--meta/recipes-devtools/fdisk/gptfdisk_1.0.4.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/fdisk/gptfdisk_1.0.4.bb b/meta/recipes-devtools/fdisk/gptfdisk_1.0.4.bb
new file mode 100644
index 0000000000..4426a795e2
--- /dev/null
+++ b/meta/recipes-devtools/fdisk/gptfdisk_1.0.4.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Utility for modifying GPT disk partitioning"
2DESCRIPTION = "GPT fdisk is a disk partitioning tool loosely modeled on Linux fdisk, but used for modifying GUID Partition Table (GPT) disks. The related FixParts utility fixes some common problems on Master Boot Record (MBR) disks."
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
6
7DEPENDS = "util-linux popt ncurses"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${PV}/${BP}.tar.gz"
10SRC_URI[md5sum] = "5ecc3c44913bb6b53d3708d1ac7ac295"
11SRC_URI[sha256sum] = "b663391a6876f19a3cd901d862423a16e2b5ceaa2f4a3b9bb681e64b9c7ba78d"
12
13UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/gptfdisk/files/gptfdisk/"
14UPSTREAM_CHECK_REGEX = "/gptfdisk/(?P<pver>(\d+[\.\-_]*)+)/"
15
16EXTRA_OEMAKE = "'CC=${CC}' 'CXX=${CXX}'"
17
18do_install() {
19 install -d ${D}${sbindir}
20 install -m 0755 cgdisk ${D}${sbindir}
21 install -m 0755 gdisk ${D}${sbindir}
22 install -m 0755 sgdisk ${D}${sbindir}
23 install -m 0755 fixparts ${D}${sbindir}
24}
25
26BBCLASSEXTEND = "native nativesdk"