summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/fakeroot/fakeroot_1.14.5.bb
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-12-10 14:03:42 +0800
committerSaul Wold <Saul.Wold@intel.com>2010-12-10 22:01:31 -0800
commit082c4e2440582cf44fbc65ba97ba3577da95ff4b (patch)
tree01aed777a90db61e0c995b333c7ead87b2900636 /meta/recipes-devtools/fakeroot/fakeroot_1.14.5.bb
parent1901134554cd14e2ad9203452dce0cf4502b08be (diff)
downloadpoky-082c4e2440582cf44fbc65ba97ba3577da95ff4b.tar.gz
fakeroot: upgrade to version 1.14.5
from 1.14.4 changes: - install to ${includedir} instead of ${STAGING_INCDIR} - fakeroot has long been under GPLv3 Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/recipes-devtools/fakeroot/fakeroot_1.14.5.bb')
-rw-r--r--meta/recipes-devtools/fakeroot/fakeroot_1.14.5.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/fakeroot/fakeroot_1.14.5.bb b/meta/recipes-devtools/fakeroot/fakeroot_1.14.5.bb
new file mode 100644
index 0000000000..2d2604f270
--- /dev/null
+++ b/meta/recipes-devtools/fakeroot/fakeroot_1.14.5.bb
@@ -0,0 +1,38 @@
1DESCRIPTION = "Provides a fake \"root environment\" by means of LD_PRELOAD and SYSV IPC or TCP trickery"
2HOMEPAGE = "http://fakeroot.alioth.debian.org/"
3SECTION = "base"
4LICENSE = "GPLv3+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
6
7# fakeroot needs getopt which is provided by the util-linux package
8RDEPENDS = "util-linux"
9RDEPENDS_virtclass-native = "util-linux-native"
10PR = "r0"
11PROVIDES += "virtual/fakeroot"
12
13SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.orig.tar.bz2 \
14 file://absolutepaths.patch"
15
16inherit autotools
17
18do_configure_prepend() {
19 # fakeroot's own bootstrap includes other autoreconf stuff we don't need here
20 # so manually create the aux directory
21 mkdir -p ${S}/build-aux
22}
23
24do_install_append() {
25 install -d ${D}${includedir}/fakeroot/
26 install -m 644 *.h ${D}${includedir}/fakeroot
27}
28
29# Compatability for the rare systems not using or having SYSV
30python () {
31 if bb.data.inherits_class("native", d) and bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
32 bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp ', d)
33}
34
35BBCLASSEXTEND = "native"
36
37SRC_URI[md5sum] = "659a1f3a36554abfc2a3eaad2fdc0604"
38SRC_URI[sha256sum] = "b035c834944bf9482027f48c388de8492e96609825265ac03f05408d0b3aae68"