summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/expect/expect_5.45.bb
diff options
context:
space:
mode:
authorMihaela Sendrea <mihaela.sendrea@enea.com>2013-11-11 01:23:53 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-20 14:03:24 +0000
commitb74b2356bf53af7ceb08008020a1f027b2737e34 (patch)
treecf15fc488e95a6a4b6f60bdbd280ffd5b36d1504 /meta/recipes-devtools/expect/expect_5.45.bb
parent75794585394585de1a13b40288bb3927ab819ba9 (diff)
downloadpoky-b74b2356bf53af7ceb08008020a1f027b2737e34.tar.gz
expect: Add recipe
Nedeed for gcc-runtime tests. Fixed build on multilib and add patch to remove !/depot/path/expect -f which caused rpm to puke on rfs generation (From OE-Core rev: 8f06d2975ed7d5db3828dc116c0df72d1161e8e5) Signed-off-by: Mihaela Sendrea <mihaela.sendrea@enea.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/expect/expect_5.45.bb')
-rw-r--r--meta/recipes-devtools/expect/expect_5.45.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-devtools/expect/expect_5.45.bb b/meta/recipes-devtools/expect/expect_5.45.bb
new file mode 100644
index 0000000000..0417ec6740
--- /dev/null
+++ b/meta/recipes-devtools/expect/expect_5.45.bb
@@ -0,0 +1,61 @@
1SUMMARY = "tool for automating interactive applications according to a script"
2DESCRIPTION = "Expect is a tool for automating interactive applications according to a script. \
3Following the script, Expect knows what can be expected from a program and what \
4the correct response should be. Expect is also useful for testing these same \
5applications. And by adding Tk, you can also wrap interactive applications in \
6X11 GUIs. An interpreted language provides branching and high-level control \
7structures to direct the dialogue. In addition, the user can take control and \
8interact directly when desired, afterward returning control to the script. \
9"
10HOMEPAGE = "http://sourceforge.net/projects/expect/"
11LICENSE="PD"
12SECTION = "devel"
13
14LIC_FILES_CHKSUM = "file://license.terms;md5=fbf2de7e9102505b1439db06fc36ce5c"
15
16DEPENDS += "tcl"
17RDEPENDS_${PN} = "tcl"
18
19inherit autotools
20
21SRC_URI = "${SOURCEFORGE_MIRROR}/expect/Expect/${PV}/${BPN}${PV}.tar.gz \
22 file://0001-configure.in.patch \
23 file://0002-tcl.m4.patch \
24 file://01-example-shebang.patch \
25 "
26SRC_URI[md5sum] = "44e1a4f4c877e9ddc5a542dfa7ecc92b"
27SRC_URI[sha256sum] = "b28dca90428a3b30e650525cdc16255d76bb6ccd65d448be53e620d95d5cc040"
28
29S = "${WORKDIR}/${BPN}${PV}"
30
31do_install_append() {
32 install -d ${D}${libdir}
33 install -m 0755 ${D}${libdir}/expect${PV}/libexpect*.so ${D}${libdir}/
34 install -m 0755 ${S}/fixline1 ${D}${libdir}/expect${PV}/
35 install -m 0755 ${S}/example/* ${D}${libdir}/expect${PV}/
36 rm ${D}${libdir}/expect${PV}/libexpect*.so
37}
38
39EXTRA_OECONF += "--includedir=${STAGING_INCDIR} \
40 --with-tcl=${STAGING_LIBDIR} \
41 --with-tclinclude=${STAGING_INCDIR}/tcl8.6 \
42 --enable-shared \
43 --enable-threads \
44 --disable-rpath \
45 "
46EXTRA_OEMAKE_install = " 'SCRIPTS=' "
47
48FILES_${PN}-dbg += "${libdir}/${BPN}${PV}/.debug \
49 ${libdir}/.debug \
50 "
51FILES_${PN}-dev = "${libdir_native}/expect${PV}/libexpect*.so \
52 ${STAGING_INCDIR}/expect.h \
53 ${STAGING_INCDIR}/expect_tcl.h \
54 ${STAGING_INCDIR}/expect_comm.h \
55 ${STAGING_INCDIR}/tcldbg.h \
56 ${includedir}/*.h \
57 "
58
59FILES_${PN} += "${libdir}/libexpect${PV}.so \
60 ${libdir}/expect${PV}/* \
61 "