summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/files/debian/0001-Ignore-differences-between-mips-machine-identifiers.patch
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-06-26 09:18:20 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-28 08:36:00 +0100
commit22781f1a89de4681f5c2421156b095c024d67de7 (patch)
tree9ab04dee2cb2a3748480338d34a7b07b2ac7842f /meta/recipes-devtools/elfutils/files/debian/0001-Ignore-differences-between-mips-machine-identifiers.patch
parent658cde8788c2faf9532d332e37a6d98b14b070c5 (diff)
downloadpoky-22781f1a89de4681f5c2421156b095c024d67de7.tar.gz
elfutils: upgrade 0.179 -> 0.180
Drop all the debian patches: they are very invasive, the use case is unclear, and rebasing them is just too hard. Refresh 0002-musl-libs.patch Add a new musl fix: 0015-config-eu.am-do-not-use-Werror.patch Add a reproducibility fix: 0001-tests-Makefile.am-compile-test_nlist-with-standard-C.patch (From OE-Core rev: 79c290a0823ee996c69bb02a82dc6ded00fae629) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/elfutils/files/debian/0001-Ignore-differences-between-mips-machine-identifiers.patch')
-rw-r--r--meta/recipes-devtools/elfutils/files/debian/0001-Ignore-differences-between-mips-machine-identifiers.patch34
1 files changed, 0 insertions, 34 deletions
diff --git a/meta/recipes-devtools/elfutils/files/debian/0001-Ignore-differences-between-mips-machine-identifiers.patch b/meta/recipes-devtools/elfutils/files/debian/0001-Ignore-differences-between-mips-machine-identifiers.patch
deleted file mode 100644
index a2983c5770..0000000000
--- a/meta/recipes-devtools/elfutils/files/debian/0001-Ignore-differences-between-mips-machine-identifiers.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From 77cb4a53c270d5854d3af24f19547bc3de825233 Mon Sep 17 00:00:00 2001
2From: James Cowgill <james410@cowgill.org.uk>
3Date: Mon, 5 Jan 2015 15:16:58 +0000
4Subject: [PATCH 1/3] Ignore differences between mips machine identifiers
5
6Little endian binaries actually use EM_MIPS so you can't tell the endianness
7from the elf machine id. Also, the EM_MIPS_RS3_LE machine is dead anyway (the
8kernel will not load binaries containing it).
9
10Signed-off-by: James Cowgill <james410@cowgill.org.uk>
11
12Upstream-Status: Pending [from debian]
13Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
14---
15 backends/mips_init.c | 6 +-----
16 1 file changed, 1 insertion(+), 5 deletions(-)
17
18Index: b/backends/mips_init.c
19===================================================================
20--- a/backends/mips_init.c
21+++ b/backends/mips_init.c
22@@ -45,11 +45,7 @@ mips_init (Elf *elf __attribute__ ((unus
23 return NULL;
24
25 /* We handle it. */
26- if (machine == EM_MIPS)
27- eh->name = "MIPS R3000 big-endian";
28- else if (machine == EM_MIPS_RS3_LE)
29- eh->name = "MIPS R3000 little-endian";
30-
31+ eh->name = "MIPS";
32 mips_init_reloc (eh);
33 HOOK (eh, reloc_simple_type);
34 HOOK (eh, return_value_location);