summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/elfutils_0.177.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-08-23 11:02:10 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-16 23:02:43 +0100
commitcc5d6ca85a40199a077403a0d0af0bd22eeefa06 (patch)
tree518e9866a124caa48ff4f6b5e747b76bcd80ea0c /meta/recipes-devtools/elfutils/elfutils_0.177.bb
parent5b1e999c41a116a77bf22e3d6546eaabf67b2946 (diff)
downloadpoky-cc5d6ca85a40199a077403a0d0af0bd22eeefa06.tar.gz
elfutils: 0.176 -> 0.177
- Update Debian patches http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.176-1.debian.tar.xz - Rebase Debian patches to 0.177 debian/hppa_backend.diff debian/mips_backend.diff debian/arm_backend.diff debian/mips_readelf_w.patch debian/testsuite-ignore-elflint.diff debian/mips_cfi.patch - Fix build failure while applying debian patches 0001-fix-compile-failure-with-debian-patches.patch - Rebase musl patches (From OE-Core rev: 35143611034758cc670e9d88bc93f97fe33c52fc) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.177.bb')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.177.bb147
1 files changed, 147 insertions, 0 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.177.bb b/meta/recipes-devtools/elfutils/elfutils_0.177.bb
new file mode 100644
index 0000000000..fcebb4b048
--- /dev/null
+++ b/meta/recipes-devtools/elfutils/elfutils_0.177.bb
@@ -0,0 +1,147 @@
1SUMMARY = "Utilities and libraries for handling compiled object files"
2HOMEPAGE = "https://sourceware.org/elfutils"
3SECTION = "base"
4LICENSE = "GPLv2 & LGPLv3+ & GPLv3+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6DEPENDS = "libtool bzip2 zlib virtual/libintl"
7DEPENDS_append_libc-musl = " argp-standalone fts musl-obstack "
8# The Debian patches below are from:
9# http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.176-1.debian.tar.xz
10SRC_URI = "https://sourceware.org/elfutils/ftp/${PV}/${BP}.tar.bz2 \
11 file://0001-dso-link-change.patch \
12 file://0002-Fix-elf_cvt_gunhash-if-dest-and-src-are-same.patch \
13 file://0003-fixheadercheck.patch \
14 file://0004-Disable-the-test-to-convert-euc-jp.patch \
15 file://0006-Fix-build-on-aarch64-musl.patch \
16 file://0007-Fix-control-path-where-we-have-str-as-uninitialized-.patch \
17 file://0001-libasm-may-link-with-libbz2-if-found.patch \
18 file://0001-libelf-elf_end.c-check-data_list.data.d.d_buf-before.patch \
19 file://debian/hppa_backend.diff \
20 file://debian/arm_backend.diff \
21 file://debian/mips_backend.diff \
22 file://debian/mips_readelf_w.patch \
23 file://debian/kfreebsd_path.patch \
24 file://debian/0001-Ignore-differences-between-mips-machine-identifiers.patch \
25 file://debian/0002-Add-support-for-mips64-abis-in-mips_retval.c.patch \
26 file://debian/0003-Add-mips-n64-relocation-format-hack.patch \
27 file://debian/hurd_path.patch \
28 file://debian/ignore_strmerge.diff \
29 file://debian/disable_werror.patch \
30 file://debian/testsuite-ignore-elflint.diff \
31 file://debian/mips_cfi.patch \
32 file://debian/0001-fix-compile-failure-with-debian-patches.patch \
33 file://0001-skip-the-test-when-gcc-not-deployed.patch \
34 file://run-ptest \
35 file://ptest.patch \
36 "
37SRC_URI_append_libc-musl = " \
38 file://musl-obstack-fts.patch \
39 file://musl-libs.patch \
40 file://musl-utils.patch \
41 file://musl-tests.patch \
42 "
43SRC_URI[md5sum] = "0b583722f911e1632544718d502aab87"
44SRC_URI[sha256sum] = "fa489deccbcae7d8c920f60d85906124c1989c591196d90e0fd668e3dc05042e"
45
46inherit autotools gettext ptest
47
48EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
49EXTRA_OECONF_append_class-native = " --without-bzlib"
50RDEPENDS_${PN}-ptest += "libasm libelf bash make coreutils ${PN}-binutils"
51
52EXTRA_OECONF_append_class-target += "--disable-tests-rpath"
53
54do_install_append() {
55 if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then
56 rm -f ${D}${bindir}/eu-objdump
57 fi
58}
59
60do_compile_ptest() {
61 cd ${B}/tests
62 oe_runmake buildtest-TESTS oecheck
63}
64
65do_install_ptest() {
66 if [ ${PTEST_ENABLED} = "1" ]; then
67 # copy the files which needed by the cases
68 TEST_FILES="strip strip.o addr2line elfcmp objdump readelf size.o nm.o nm elflint"
69 install -d -m 755 ${D}${PTEST_PATH}/src
70 install -d -m 755 ${D}${PTEST_PATH}/libelf
71 install -d -m 755 ${D}${PTEST_PATH}/libdw
72 for test_file in ${TEST_FILES}; do
73 if [ -f ${B}/src/${test_file} ]; then
74 cp -r ${B}/src/${test_file} ${D}${PTEST_PATH}/src
75 fi
76 done
77 cp ${D}${libdir}/libelf-${PV}.so ${D}${PTEST_PATH}/libelf/libelf.so
78 cp ${D}${libdir}/libdw-${PV}.so ${D}${PTEST_PATH}/libdw/libdw.so
79 cp -r ${S}/tests/ ${D}${PTEST_PATH}
80 cp -r ${B}/tests/* ${D}${PTEST_PATH}/tests
81 cp -r ${B}/config.h ${D}${PTEST_PATH}
82 cp -r ${B}/backends ${D}${PTEST_PATH}
83 sed -i '/^Makefile:/c Makefile:' ${D}${PTEST_PATH}/tests/Makefile
84 find ${D}${PTEST_PATH} -type f -name *.[hoc] | xargs -i rm {}
85 fi
86}
87
88EXTRA_OEMAKE_class-native = ""
89EXTRA_OEMAKE_class-nativesdk = ""
90
91BBCLASSEXTEND = "native nativesdk"
92
93# Package utilities separately
94PACKAGES =+ "${PN}-binutils libelf libasm libdw"
95
96# shared libraries are licensed GPLv2 or GPLv3+, binaries GPLv3+
97# according to NEWS file:
98# "The license is now GPLv2/LGPLv3+ for the libraries and GPLv3+ for stand-alone
99# programs. There is now also a formal CONTRIBUTING document describing how to
100# submit patches."
101LICENSE_${PN}-binutils = "GPLv3+"
102LICENSE_${PN} = "GPLv3+"
103LICENSE_libelf = "GPLv2 | LGPLv3+"
104LICENSE_libasm = "GPLv2 | LGPLv3+"
105LICENSE_libdw = "GPLv2 | LGPLv3+"
106
107FILES_${PN}-binutils = "\
108 ${bindir}/eu-addr2line \
109 ${bindir}/eu-ld \
110 ${bindir}/eu-nm \
111 ${bindir}/eu-readelf \
112 ${bindir}/eu-size \
113 ${bindir}/eu-strip"
114
115FILES_libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*"
116FILES_libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*"
117FILES_libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*"
118# Some packages have the version preceeding the .so instead properly
119# versioned .so.<version>, so we need to reorder and repackage.
120#FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so"
121#FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so"
122
123# The package contains symlinks that trip up insane
124INSANE_SKIP_${MLPREFIX}libdw = "dev-so"
125
126# avoid stripping some generated binaries otherwise some of the tests such as test-nlist,
127# run-strip-reloc.sh, run-strip-strmerge.sh and so on will fail
128INHIBIT_PACKAGE_STRIP_FILES = "\
129 ${PKGD}${PTEST_PATH}/tests/test-nlist \
130 ${PKGD}${PTEST_PATH}/tests/elfstrmerge \
131 ${PKGD}${PTEST_PATH}/tests/backtrace-child \
132 ${PKGD}${PTEST_PATH}/tests/backtrace-data \
133 ${PKGD}${PTEST_PATH}/tests/deleted \
134 ${PKGD}${PTEST_PATH}/src/strip \
135 ${PKGD}${PTEST_PATH}/src/addr2line \
136 ${PKGD}${PTEST_PATH}/src/elfcmp \
137 ${PKGD}${PTEST_PATH}/src/objdump \
138 ${PKGD}${PTEST_PATH}/src/readelf \
139 ${PKGD}${PTEST_PATH}/src/nm \
140 ${PKGD}${PTEST_PATH}/src/elflint \
141 ${PKGD}${PTEST_PATH}/libelf/libelf.so \
142 ${PKGD}${PTEST_PATH}/libdw/libdw.so \
143 ${PKGD}${PTEST_PATH}/backends/libebl_i386.so \
144 ${PKGD}${PTEST_PATH}/backends/libebl_x86_64.so \
145"
146
147PRIVATE_LIBS_${PN}-ptest = "libdw.so.1 libelf.so.1"