summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/elfutils_0.168.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-08-16 04:31:18 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-18 10:40:26 +0100
commit70de26076f36205b914be1b1911e5fc0afd65edb (patch)
tree8462c68ee795e2ac168c81db0ed52fae670f554a /meta/recipes-devtools/elfutils/elfutils_0.168.bb
parenta02826add027f71d1fca56547b2b72db28b1005f (diff)
downloadpoky-70de26076f36205b914be1b1911e5fc0afd65edb.tar.gz
elfutils: 0.168 -> 0.170
The 0.170 Fixed CVE issues - CVE-2017-7608 - CVE-2017-7612 - CVE-2017-7611 - CVE-2017-7610 - CVE-2016-10255 - CVE-2017-7613 - CVE-2017-7609 - CVE-2016-10254 - CVE-2017-7607 Rebase patches to 0.170 - dso-link-change.patch -> 0001 - Fix_elf_cvt_gunhash.patch -> 0002 - fixheadercheck.patch -> 0003 - 0001-remove-the-unneed-checking.patch -> 0004 - 0001-fix-a-stack-usage-warning.patch -> 0005 - aarch64_uio.patch -> 0006 - shadow.patch -> 0007 - 0001-build-Provide-alternatives-for-glibc-assumptions-hel.patch -> 0008 - debian/mips_backend.diff -> debian/mips_backend.patch Drop obsolete patches - 0001-elf_getarsym-Silence-Werror-maybe-uninitialized-fals.patch Upstream fixed it https://sourceware.org/git/?p=elfutils.git;a=commit;h=7114c513fbebcca8b76796b7f64b57447ba383e1 - Fix_one_GCC7_warning.patch It is a backported patch https://sourceware.org/git/?p=elfutils.git;a=commit;h=93c51144c3f664d4e9709da75a1d0fa00ea0fe95 - Drop debian patches, they modify test case. debian/testsuite-ignore-elflint.diff debian/kfreebsd_path.patch debian/hurd_path.patch debian/ignore_strmerge.diff (From OE-Core rev: 4ca17f9275c81f27498b7ac07d9fe7e8193fdd71) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.168.bb')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.168.bb84
1 files changed, 0 insertions, 84 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.168.bb b/meta/recipes-devtools/elfutils/elfutils_0.168.bb
deleted file mode 100644
index 0717616ec0..0000000000
--- a/meta/recipes-devtools/elfutils/elfutils_0.168.bb
+++ /dev/null
@@ -1,84 +0,0 @@
1SUMMARY = "Utilities and libraries for handling compiled object files"
2HOMEPAGE = "https://sourceware.org/elfutils"
3SECTION = "base"
4LICENSE = "(GPLv3 & Elfutils-Exception)"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6DEPENDS = "libtool bzip2 zlib virtual/libintl"
7DEPENDS_append_libc-musl = " argp-standalone fts "
8SRC_URI = "https://sourceware.org/elfutils/ftp/${PV}/${BP}.tar.bz2"
9SRC_URI[md5sum] = "52adfa40758d0d39e5d5c57689bf38d6"
10SRC_URI[sha256sum] = "b88d07893ba1373c7dd69a7855974706d05377766568a7d9002706d5de72c276"
11
12SRC_URI += "\
13 file://dso-link-change.patch \
14 file://Fix_elf_cvt_gunhash.patch \
15 file://fixheadercheck.patch \
16 file://0001-elf_getarsym-Silence-Werror-maybe-uninitialized-fals.patch \
17 file://0001-remove-the-unneed-checking.patch \
18 file://0001-fix-a-stack-usage-warning.patch \
19 file://aarch64_uio.patch \
20 file://Fix_one_GCC7_warning.patch \
21 file://shadow.patch \
22"
23
24# pick the patch from debian
25# http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.168-0.2.debian.tar.xz
26SRC_URI += "\
27 file://debian/hppa_backend.diff \
28 file://debian/arm_backend.diff \
29 file://debian/mips_backend.diff \
30 file://debian/testsuite-ignore-elflint.diff \
31 file://debian/mips_readelf_w.patch \
32 file://debian/kfreebsd_path.patch \
33 file://debian/0001-Ignore-differences-between-mips-machine-identifiers.patch \
34 file://debian/0002-Add-support-for-mips64-abis-in-mips_retval.c.patch \
35 file://debian/0003-Add-mips-n64-relocation-format-hack.patch \
36 file://debian/hurd_path.patch \
37 file://debian/ignore_strmerge.diff \
38"
39# Fix the patches from Debian with GCC7
40SRC_URI += "file://fallthrough.patch"
41SRC_URI_append_libc-musl = " file://0001-build-Provide-alternatives-for-glibc-assumptions-hel.patch "
42
43# The buildsystem wants to generate 2 .h files from source using a binary it just built,
44# which can not pass the cross compiling, so let's work around it by adding 2 .h files
45# along with the do_configure_prepend()
46
47inherit autotools gettext
48
49EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
50EXTRA_OECONF_append_class-native = " --without-bzlib"
51
52do_install_append() {
53 if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then
54 rm -f ${D}${bindir}/eu-objdump
55 fi
56}
57
58EXTRA_OEMAKE_class-native = ""
59EXTRA_OEMAKE_class-nativesdk = ""
60
61ALLOW_EMPTY_${PN}_libc-musl = "1"
62
63BBCLASSEXTEND = "native nativesdk"
64
65# Package utilities separately
66PACKAGES =+ "${PN}-binutils libelf libasm libdw"
67FILES_${PN}-binutils = "\
68 ${bindir}/eu-addr2line \
69 ${bindir}/eu-ld \
70 ${bindir}/eu-nm \
71 ${bindir}/eu-readelf \
72 ${bindir}/eu-size \
73 ${bindir}/eu-strip"
74
75FILES_libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*"
76FILES_libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*"
77FILES_libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*"
78# Some packages have the version preceeding the .so instead properly
79# versioned .so.<version>, so we need to reorder and repackage.
80#FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so"
81#FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so"
82
83# The package contains symlinks that trip up insane
84INSANE_SKIP_${MLPREFIX}libdw = "dev-so"