diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2017-02-06 04:34:46 -0500 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-02-15 20:06:42 -0800 |
commit | f0a300c44ddcc44fd81a6362944411f138d96aa9 (patch) | |
tree | 79da36efe6d558a3a3ea3afe82d5ecfed2879647 /meta/recipes-devtools/elfutils/elfutils_0.166.bb | |
parent | edd51e8659ca03a8f7a06f563e90fb4f0e5aa060 (diff) | |
download | poky-f0a300c44ddcc44fd81a6362944411f138d96aa9.tar.gz |
elfutils: 0.166 -> 0.168
- Backport patches from debian to 0.168 and add US tags.
- Rebase 0001-build-Provide-alternatives-for-glibc-assumptions-hel.patch to support libc musl
(From OE-Core rev: 13e5819dc4ef44d99d0f22686365fd3c988d6bce)
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.166.bb')
-rw-r--r-- | meta/recipes-devtools/elfutils/elfutils_0.166.bb | 89 |
1 files changed, 0 insertions, 89 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.166.bb b/meta/recipes-devtools/elfutils/elfutils_0.166.bb deleted file mode 100644 index 5c436d3864..0000000000 --- a/meta/recipes-devtools/elfutils/elfutils_0.166.bb +++ /dev/null | |||
@@ -1,89 +0,0 @@ | |||
1 | SUMMARY = "Utilities and libraries for handling compiled object files" | ||
2 | HOMEPAGE = "https://fedorahosted.org/elfutils" | ||
3 | SECTION = "base" | ||
4 | LICENSE = "(GPLv3 & Elfutils-Exception)" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
6 | DEPENDS = "libtool bzip2 zlib virtual/libintl" | ||
7 | DEPENDS_append_libc-musl = " argp-standalone fts " | ||
8 | |||
9 | SRC_URI = "https://fedorahosted.org/releases/e/l/elfutils/${PV}/${BP}.tar.bz2" | ||
10 | SRC_URI[md5sum] = "d4e462b7891915dc5326bccefa2024ff" | ||
11 | SRC_URI[sha256sum] = "3c056914c8a438b210be0d790463b960fc79d234c3f05ce707cbff80e94cba30" | ||
12 | |||
13 | SRC_URI += "\ | ||
14 | file://dso-link-change.patch \ | ||
15 | file://Fix_elf_cvt_gunhash.patch \ | ||
16 | file://fixheadercheck.patch \ | ||
17 | file://0001-elf_getarsym-Silence-Werror-maybe-uninitialized-fals.patch \ | ||
18 | file://0001-remove-the-unneed-checking.patch \ | ||
19 | file://0001-fix-a-stack-usage-warning.patch \ | ||
20 | file://aarch64_uio.patch \ | ||
21 | file://shadow.patch \ | ||
22 | " | ||
23 | |||
24 | # pick the patch from debian | ||
25 | # http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.164-1.debian.tar.xz | ||
26 | SRC_URI += "\ | ||
27 | file://hppa_backend.diff \ | ||
28 | file://arm_backend.diff \ | ||
29 | file://mips_backend.diff \ | ||
30 | file://m68k_backend.diff \ | ||
31 | file://testsuite-ignore-elflint.diff \ | ||
32 | file://mips_readelf_w.patch \ | ||
33 | file://kfreebsd_path.patch \ | ||
34 | file://0001-Ignore-differences-between-mips-machine-identifiers.patch \ | ||
35 | file://0002-Add-support-for-mips64-abis-in-mips_retval.c.patch \ | ||
36 | file://0003-Add-mips-n64-relocation-format-hack.patch \ | ||
37 | file://uclibc-support.patch \ | ||
38 | file://elfcmp-fix-self-comparision.patch \ | ||
39 | " | ||
40 | SRC_URI_append_libc-musl = " file://0001-build-Provide-alternatives-for-glibc-assumptions-hel.patch " | ||
41 | |||
42 | # The buildsystem wants to generate 2 .h files from source using a binary it just built, | ||
43 | # which can not pass the cross compiling, so let's work around it by adding 2 .h files | ||
44 | # along with the do_configure_prepend() | ||
45 | |||
46 | inherit autotools gettext | ||
47 | |||
48 | EXTRA_OECONF = "--program-prefix=eu- --without-lzma" | ||
49 | EXTRA_OECONF_append_class-native = " --without-bzlib" | ||
50 | EXTRA_OECONF_append_libc-uclibc = " --enable-uclibc" | ||
51 | |||
52 | do_install_append() { | ||
53 | if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then | ||
54 | rm -f ${D}${bindir}/eu-objdump | ||
55 | fi | ||
56 | } | ||
57 | |||
58 | # we can not build complete elfutils when using uclibc | ||
59 | # but some recipes e.g. gcc 4.5 depends on libelf so we | ||
60 | # build only libelf for uclibc case | ||
61 | |||
62 | EXTRA_OEMAKE_libc-uclibc = "-C libelf" | ||
63 | EXTRA_OEMAKE_class-native = "" | ||
64 | EXTRA_OEMAKE_class-nativesdk = "" | ||
65 | |||
66 | ALLOW_EMPTY_${PN}_libc-musl = "1" | ||
67 | |||
68 | BBCLASSEXTEND = "native nativesdk" | ||
69 | |||
70 | # Package utilities separately | ||
71 | PACKAGES =+ "${PN}-binutils libelf libasm libdw" | ||
72 | FILES_${PN}-binutils = "\ | ||
73 | ${bindir}/eu-addr2line \ | ||
74 | ${bindir}/eu-ld \ | ||
75 | ${bindir}/eu-nm \ | ||
76 | ${bindir}/eu-readelf \ | ||
77 | ${bindir}/eu-size \ | ||
78 | ${bindir}/eu-strip" | ||
79 | |||
80 | FILES_libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*" | ||
81 | FILES_libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*" | ||
82 | FILES_libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*" | ||
83 | # Some packages have the version preceeding the .so instead properly | ||
84 | # versioned .so.<version>, so we need to reorder and repackage. | ||
85 | #FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so" | ||
86 | #FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so" | ||
87 | |||
88 | # The package contains symlinks that trip up insane | ||
89 | INSANE_SKIP_${MLPREFIX}libdw = "dev-so" | ||