diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2014-05-28 16:49:57 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-06-03 16:49:19 +0100 |
commit | 4b616f06c1764b6c36d8d9e8fda6897682d91e4b (patch) | |
tree | 6b964d24abb6b05a8c529d4e7982848da8d9f347 /meta/recipes-devtools/elfutils/elfutils_0.155.bb | |
parent | 5f45b006046b3685a1141f9dd4f576fd2af6395b (diff) | |
download | poky-4b616f06c1764b6c36d8d9e8fda6897682d91e4b.tar.gz |
elfutils: upgrade to 0.158
Add 'm4-biarch.m4-tweak-AC_RUN_IFELSE-for-cross-compiling.patch' to fix cross compiling failure;
Rebase 'elf_additions.diff' for 0.158;
Drop obsolete patches:
- nm-Fix-size-passed-to-snprintf-for-invalid-sh_name-case.patch
- elfutils-ar-c-fix-num-passed-to-memset.patch
- fix-build-gcc-4.8.patch
Pick patches from debian:
http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.158-2.debian.tar.xz
We could not directly add elfutils_0.158-2.debian.tar.xz to SRC_URI, because it
contains other souce codes which are not pathces.
(From OE-Core rev: d9c7a02240ce37d5b2569d9177e8ba534b9295ce)
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.155.bb')
-rw-r--r-- | meta/recipes-devtools/elfutils/elfutils_0.155.bb | 88 |
1 files changed, 0 insertions, 88 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.155.bb b/meta/recipes-devtools/elfutils/elfutils_0.155.bb deleted file mode 100644 index b1f410c0f6..0000000000 --- a/meta/recipes-devtools/elfutils/elfutils_0.155.bb +++ /dev/null | |||
@@ -1,88 +0,0 @@ | |||
1 | SUMMARY = "Utilities and libraries for handling compiled object files" | ||
2 | HOMEPAGE = "https://fedorahosted.org/elfutils" | ||
3 | SECTION = "base" | ||
4 | LICENSE = "(GPLv3 & Elfutils-Exception)" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
6 | DEPENDS = "libtool bzip2 zlib virtual/libintl" | ||
7 | |||
8 | SRC_URI = "https://fedorahosted.org/releases/e/l/elfutils/${PV}/elfutils-${PV}.tar.bz2" | ||
9 | |||
10 | SRC_URI[md5sum] = "163a5712b86f6bdfebdf233cc6e2192d" | ||
11 | SRC_URI[sha256sum] = "68444a4526416ffd68852ec3c6a40ceddcca46538297322405319884c5d30ed8" | ||
12 | |||
13 | SRC_URI += "\ | ||
14 | file://redhat-portability.diff \ | ||
15 | file://redhat-robustify.diff \ | ||
16 | file://hppa_backend.diff \ | ||
17 | file://arm_backend.diff \ | ||
18 | file://mips_backend.diff \ | ||
19 | file://m68k_backend.diff \ | ||
20 | file://elf_additions.diff \ | ||
21 | file://mempcpy.patch \ | ||
22 | file://dso-link-change.patch \ | ||
23 | file://nm-Fix-size-passed-to-snprintf-for-invalid-sh_name-case.patch \ | ||
24 | file://elfutils-ar-c-fix-num-passed-to-memset.patch \ | ||
25 | file://fix-build-gcc-4.8.patch \ | ||
26 | " | ||
27 | # Only apply when building uclibc based target recipe | ||
28 | SRC_URI_append_libc-uclibc = " file://uclibc-support.patch" | ||
29 | |||
30 | # The buildsystem wants to generate 2 .h files from source using a binary it just built, | ||
31 | # which can not pass the cross compiling, so let's work around it by adding 2 .h files | ||
32 | # along with the do_configure_prepend() | ||
33 | |||
34 | SRC_URI += "\ | ||
35 | file://i386_dis.h \ | ||
36 | file://x86_64_dis.h \ | ||
37 | " | ||
38 | inherit autotools gettext | ||
39 | |||
40 | EXTRA_OECONF = "--program-prefix=eu- --without-lzma" | ||
41 | EXTRA_OECONF_append_class-native = " --without-bzlib" | ||
42 | EXTRA_OECONF_append_libc-uclibc = " --enable-uclibc" | ||
43 | |||
44 | do_configure_prepend() { | ||
45 | sed -i '/^i386_dis.h:/,+4 {/.*/d}' ${S}/libcpu/Makefile.am | ||
46 | |||
47 | cp ${WORKDIR}/*dis.h ${S}/libcpu | ||
48 | } | ||
49 | |||
50 | do_install_append() { | ||
51 | if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then | ||
52 | rm ${D}${bindir}/eu-objdump | ||
53 | fi | ||
54 | } | ||
55 | |||
56 | # we can not build complete elfutils when using uclibc | ||
57 | # but some recipes e.g. gcc 4.5 depends on libelf so we | ||
58 | # build only libelf for uclibc case | ||
59 | |||
60 | EXTRA_OEMAKE_libc-uclibc = "-C libelf" | ||
61 | EXTRA_OEMAKE_class-native = "" | ||
62 | EXTRA_OEMAKE_class-nativesdk = "" | ||
63 | |||
64 | BBCLASSEXTEND = "native nativesdk" | ||
65 | |||
66 | # Package utilities separately | ||
67 | PACKAGES =+ "${PN}-binutils libelf libasm libdw libdw-dev libasm-dev libelf-dev" | ||
68 | FILES_${PN}-binutils = "\ | ||
69 | ${bindir}/eu-addr2line \ | ||
70 | ${bindir}/eu-ld \ | ||
71 | ${bindir}/eu-nm \ | ||
72 | ${bindir}/eu-readelf \ | ||
73 | ${bindir}/eu-size \ | ||
74 | ${bindir}/eu-strip" | ||
75 | |||
76 | FILES_libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*" | ||
77 | FILES_libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*" | ||
78 | FILES_libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*" | ||
79 | FILES_libelf-dev = "${libdir}/libelf.so ${includedir}" | ||
80 | FILES_libasm-dev = "${libdir}/libasm.so ${includedir}/elfutils/libasm.h" | ||
81 | FILES_libdw-dev = "${libdir}/libdw.so ${includedir}/dwarf.h ${includedir}/elfutils/libdw*.h" | ||
82 | # Some packages have the version preceeding the .so instead properly | ||
83 | # versioned .so.<version>, so we need to reorder and repackage. | ||
84 | #FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so" | ||
85 | #FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so" | ||
86 | |||
87 | # The package contains symlinks that trip up insane | ||
88 | INSANE_SKIP_${MLPREFIX}libdw = "dev-so" | ||