summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/elfutils_0.148.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-02 12:04:08 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-07 20:05:31 +0000
commit2345af9b4829ed3eed5abf60f2483055649f8af7 (patch)
tree96a9a31e4b1957b93c4fe3eb669117d2752caf0d /meta/recipes-devtools/elfutils/elfutils_0.148.bb
parentc4901328fe5cf912c0965e5b011b64a95a9bcb9d (diff)
downloadpoky-uninative-1.5.tar.gz
recipes: Move out stale GPLv2 versions to a seperate layeruninative-1.5
These are recipes where the upstream has moved to GPLv3 and these old versions are the last ones under the GPLv2 license. There are several reasons for making this move. There is a different quality of service with these recipes in that they don't get security fixes and upstream no longer care about them, in fact they're actively hostile against people using old versions. The recipes tend to need a different kind of maintenance to work with changes in the wider ecosystem and there needs to be isolation between changes made in the v3 versions and those in the v2 versions. There are probably better ways to handle a "non-GPLv3" system but right now having these in OE-Core makes them look like a first class citizen when I believe they have potential for a variety of undesireable issues. Moving them into a separate layer makes their different needs clearer, it also makes it clear how many of these there are. Some are probably not needed (e.g. mc), I also wonder whether some are useful (e.g. gmp) since most things that use them are GPLv3 only already. Someone could now more clearly see how to streamline the list of recipes here. I'm proposing we mmove to this separate layer for 2.3 with its future maintinership and testing to be determined in 2.4 and beyond. (From OE-Core rev: 19b7e950346fb1dde6505c45236eba6cd9b33b4b) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.148.bb')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.148.bb91
1 files changed, 0 insertions, 91 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.148.bb b/meta/recipes-devtools/elfutils/elfutils_0.148.bb
deleted file mode 100644
index 6080c179fa..0000000000
--- a/meta/recipes-devtools/elfutils/elfutils_0.148.bb
+++ /dev/null
@@ -1,91 +0,0 @@
1SUMMARY = "Utilities and libraries for handling compiled object files"
2HOMEPAGE = "https://fedorahosted.org/elfutils"
3SECTION = "base"
4LICENSE = "(GPL-2+ & Elfutils-Exception)"
5LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3\
6 file://EXCEPTION;md5=570adcb0c1218ab57f2249c67d0ce417"
7DEPENDS = "libtool bzip2 zlib virtual/libintl"
8
9PR = "r11"
10
11SRC_URI = "https://fedorahosted.org/releases/e/l/${BPN}/${BP}.tar.bz2"
12
13SRC_URI[md5sum] = "a0bed1130135f17ad27533b0034dba8d"
14SRC_URI[sha256sum] = "8aebfa4a745db21cf5429c9541fe482729b62efc7e53e9110151b4169fe887da"
15
16# pick the patch from debian
17# http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.148-1.debian.tar.gz
18
19SRC_URI += "\
20 file://redhat-portability.diff \
21 file://redhat-robustify.diff \
22 file://hppa_backend.diff \
23 file://arm_backend.diff \
24 file://mips_backend.diff \
25 file://m68k_backend.diff \
26 file://testsuite-ignore-elflint.diff \
27 file://elf_additions.diff \
28 file://elfutils-fsize.patch \
29 file://remove-unused.patch \
30 file://fix_for_gcc-4.7.patch \
31 file://dso-link-change.patch \
32 file://nm-Fix-size-passed-to-snprintf-for-invalid-sh_name-case.patch \
33 file://elfutils-ar-c-fix-num-passed-to-memset.patch \
34 file://Fix_elf_cvt_gunhash.patch \
35 file://elf_begin.c-CVE-2014-9447-fix.patch \
36 file://fix-build-gcc-4.8.patch \
37 file://gcc6.patch \
38"
39# Only apply when building uclibc based target recipe
40SRC_URI_append_libc-uclibc = " file://uclibc-support-for-elfutils-0.148.patch"
41
42# The buildsystem wants to generate 2 .h files from source using a binary it just built,
43# which can not pass the cross compiling, so let's work around it by adding 2 .h files
44# along with the do_configure_prepend()
45
46SRC_URI += "\
47 file://i386_dis.h \
48 file://x86_64_dis.h \
49"
50inherit autotools gettext
51
52EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
53EXTRA_OECONF_append_class-native = " --without-bzlib"
54EXTRA_OECONF_append_libc-uclibc = " --enable-uclibc"
55
56do_configure_prepend() {
57 sed -i '/^i386_dis.h:/,+4 {/.*/d}' ${S}/libcpu/Makefile.am
58
59 cp ${WORKDIR}/*dis.h ${S}/libcpu
60}
61
62# we can not build complete elfutils when using uclibc
63# but some recipes e.g. gcc 4.5 depends on libelf so we
64# build only libelf for uclibc case
65
66EXTRA_OEMAKE_libc-uclibc = "-C libelf"
67EXTRA_OEMAKE_class-native = ""
68EXTRA_OEMAKE_class-nativesdk = ""
69
70BBCLASSEXTEND = "native nativesdk"
71
72# Package utilities separately
73PACKAGES =+ "${PN}-binutils libelf libasm libdw"
74FILES_${PN}-binutils = "\
75 ${bindir}/eu-addr2line \
76 ${bindir}/eu-ld \
77 ${bindir}/eu-nm \
78 ${bindir}/eu-readelf \
79 ${bindir}/eu-size \
80 ${bindir}/eu-strip"
81
82FILES_libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*"
83FILES_libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*"
84FILES_libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*"
85# Some packages have the version preceeding the .so instead properly
86# versioned .so.<version>, so we need to reorder and repackage.
87#FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so"
88#FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so"
89
90# The package contains symlinks that trip up insane
91INSANE_SKIP_${MLPREFIX}libdw = "dev-so"