summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/elfutils_0.148.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-05-23 18:53:59 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-25 15:50:56 +0100
commita49cc20ad2e28cdd974f79da3463597dd31ab647 (patch)
treee1f5eb44172d3ef7ba683c6b8594abede8ca9d00 /meta/recipes-devtools/elfutils/elfutils_0.148.bb
parentc792ca026a92682cb7aff44fbfb66ba80568c037 (diff)
downloadpoky-a49cc20ad2e28cdd974f79da3463597dd31ab647.tar.gz
elfutils_0.148.bb: Fix compilation on uclibc
Currently all components of elfutils dont compile with uclibc but elfutils is one part which is needed by other recipes e.g. gcc 4.5 to compile. we make adjustments so that when compiling for uclibc targets it _only_ builds and packages libelf use --enable-uclibc only when building for uclibc targets The supporting patch is also needed for compiling with uclibc to specify -lintl and -luargp on linker commandline Add missing inherit on gettext (From OE-Core rev: e21267f1837b25fec4443dbf4367e501639541bd) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.148.bb')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.148.bb15
1 files changed, 12 insertions, 3 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.148.bb b/meta/recipes-devtools/elfutils/elfutils_0.148.bb
index df933f61ae..115ff9bde6 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.148.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.148.bb
@@ -30,6 +30,9 @@ SRC_URI += "\
30 file://remove-unused.patch \ 30 file://remove-unused.patch \
31 file://mempcpy.patch \ 31 file://mempcpy.patch \
32" 32"
33# Only apply when building uclibc based target recipe
34SRC_URI_append_libc-uclibc = " ${@['', 'file://uclibc-support.patch']['${PN}' == '${BPN}']}"
35
33# The buildsystem wants to generate 2 .h files from source using a binary it just built, 36# The buildsystem wants to generate 2 .h files from source using a binary it just built,
34# which can not pass the cross compiling, so let's work around it by adding 2 .h files 37# which can not pass the cross compiling, so let's work around it by adding 2 .h files
35# along with the do_configure_prepend() 38# along with the do_configure_prepend()
@@ -38,9 +41,10 @@ SRC_URI += "\
38 file://i386_dis.h \ 41 file://i386_dis.h \
39 file://x86_64_dis.h \ 42 file://x86_64_dis.h \
40" 43"
41inherit autotools 44inherit autotools gettext
42 45
43EXTRA_OECONF = "--program-prefix=eu-" 46EXTRA_OECONF = "--program-prefix=eu-"
47EXTRA_OECONF_append_libc-uclibc = " ${@['', '--enable-uclibc']['${PN}' == '${BPN}']}"
44 48
45do_configure_prepend() { 49do_configure_prepend() {
46 sed -i 's:./i386_gendis:echo\ \#:g' ${S}/libcpu/Makefile.am 50 sed -i 's:./i386_gendis:echo\ \#:g' ${S}/libcpu/Makefile.am
@@ -48,8 +52,13 @@ do_configure_prepend() {
48 cp ${WORKDIR}/*dis.h ${S}/libcpu 52 cp ${WORKDIR}/*dis.h ${S}/libcpu
49} 53}
50 54
51# Only append ldflags for target recipe 55# we can not build complete elfutils when using uclibc
52TARGET_LDFLAGS_libc-uclibc += "${@['', '-lintl -luargp']['${PN}' == '${BPN}']}" 56# but some recipes e.g. gcc 4.5 depends on libelf so we
57# build only libelf for uclibc case
58
59EXTRA_OEMAKE_libc-uclibc = "-C libelf"
60EXTRA_OEMAKE_virtclass-native = ""
61EXTRA_OEMAKE_virtclass-nativesdk = ""
53 62
54BBCLASSEXTEND = "native nativesdk" 63BBCLASSEXTEND = "native nativesdk"
55 64