summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/dwarfsrcfiles/dwarfsrcfiles.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-11-10 17:38:59 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-02 17:24:36 +0000
commit0d5475a3b28d9e2c9273967a03726bb6c427bd11 (patch)
tree9c9149b6987b0aeb9786511256e7fe5de0448624 /meta/recipes-devtools/dwarfsrcfiles/dwarfsrcfiles.bb
parentb09bad9de0e2c848dea1592f06d6a30d194ec575 (diff)
downloadpoky-0d5475a3b28d9e2c9273967a03726bb6c427bd11.tar.gz
package.bbclass: replace rpm/debugedit with dwarfsrcfiles
Debugedit provided by rpm 4.14 is rewriting binaries in-place, and was found to produce broken output at least for grub: http://lists.openembedded.org/pipermail/openembedded-core/2017-November/143989.html A replacement utility was suggested via private mail: https://lists.fedorahosted.org/archives/list/elfutils-devel@lists.fedorahosted.org/message/VZP4G5N2ELYZEDAB3QYLXYHDGX4WMCUF/ (From OE-Core rev: f2e6e1d3bfd4c92ef0f5ed4721fd9050c59dafca) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/dwarfsrcfiles/dwarfsrcfiles.bb')
-rw-r--r--meta/recipes-devtools/dwarfsrcfiles/dwarfsrcfiles.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/dwarfsrcfiles/dwarfsrcfiles.bb b/meta/recipes-devtools/dwarfsrcfiles/dwarfsrcfiles.bb
new file mode 100644
index 0000000000..c59a006eda
--- /dev/null
+++ b/meta/recipes-devtools/dwarfsrcfiles/dwarfsrcfiles.bb
@@ -0,0 +1,22 @@
1SUMMARY = "A small utility for printing debig source file locations embedded in binaries"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://../dwarfsrcfiles.c;md5=31483894e453a77acbb67847565f1b5c;beginline=1;endline=8"
4
5SRC_URI = "file://dwarfsrcfiles.c"
6BBCLASSEXTEND = "native"
7DEPENDS = "elfutils"
8DEPENDS_append_libc-musl = " argp-standalone"
9
10do_compile () {
11 ${CC} ${CFLAGS} ${LDFLAGS} -o dwarfsrcfiles ../dwarfsrcfiles.c -lelf -ldw
12}
13
14do_compile_libc-musl () {
15 ${CC} ${CFLAGS} ${LDFLAGS} -o dwarfsrcfiles ../dwarfsrcfiles.c -lelf -ldw -largp
16}
17
18do_install () {
19 install -d ${D}${bindir}
20 install -t ${D}${bindir} dwarfsrcfiles
21}
22