summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/dpkg/run-postinsts_1.0.bb
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-22 13:57:13 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-22 13:57:13 +0000
commitcfe12efb5ec9586dab6961f141d52b103bd8b1d1 (patch)
tree7108e22aa7ddf6cfc2f1b6c6b73a811187706ecb /meta/recipes-devtools/dpkg/run-postinsts_1.0.bb
parent762fd6b7b3b22d7a8cb80ef9e9ba62e7ef21af3e (diff)
downloadpoky-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.gz
Meta: Recipe Reogranization
This is the next stage of recipe reorganization, in this stage many recipes where moved to a new meta-demoapps layer since this is more appropriate for demo usage then the core. Additional some recipes were moved to meta-extras to indicate they may be depercated at a future time. A number of recipes were modified since dependencies need to be corrected. Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta/recipes-devtools/dpkg/run-postinsts_1.0.bb')
-rw-r--r--meta/recipes-devtools/dpkg/run-postinsts_1.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/dpkg/run-postinsts_1.0.bb b/meta/recipes-devtools/dpkg/run-postinsts_1.0.bb
new file mode 100644
index 0000000000..44e840ed13
--- /dev/null
+++ b/meta/recipes-devtools/dpkg/run-postinsts_1.0.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Run postinstall scripts on device using awk"
2SECTION = "devel"
3PR = "r6"
4LICENSE = "MIT"
5
6SRC_URI = "file://run-postinsts file://run-postinsts.awk"
7
8INITSCRIPT_NAME = "run-postinsts"
9INITSCRIPT_PARAMS = "start 98 S ."
10
11inherit update-rc.d
12
13do_configure() {
14 :
15}
16
17do_compile () {
18 :
19}
20
21do_install() {
22 install -d ${D}${sysconfdir}/init.d/
23 install -m 0755 ${WORKDIR}/run-postinsts ${D}${sysconfdir}/init.d/
24
25 install -d ${D}${datadir}/${PN}/
26 install -m 0644 ${WORKDIR}/run-postinsts.awk ${D}${datadir}/${PN}/
27}