diff options
author | Scott Garman <scott.a.garman@intel.com> | 2011-02-09 19:44:21 -0800 |
---|---|---|
committer | Saul Wold <sgw@linux.intel.com> | 2011-02-16 07:45:19 -0800 |
commit | 1cd61f6e7dbb2f879adeba83711f21ea5bb5d312 (patch) | |
tree | 68dbb8b820899c27108b104c8579e8e48484237f /meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb | |
parent | 1e24e9c842f1f9b8e9543cc2ee2d2a85f10274e6 (diff) | |
download | poky-1cd61f6e7dbb2f879adeba83711f21ea5bb5d312.tar.gz |
docbook-utils-native: new recipe v0.6.14
Recipe derived from OpenEmbedded. Starting with a -native only
version for now.
Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb')
-rw-r--r-- | meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb | 48 |
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb b/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb new file mode 100644 index 0000000000..2263c0a982 --- /dev/null +++ b/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb | |||
@@ -0,0 +1,48 @@ | |||
1 | SUMMARY = "Utilities for formatting and manipulating DocBook documents" | ||
2 | DESCRIPTION = "A collection of all the free software tools you need to \ | ||
3 | work on and format DocBook documents." | ||
4 | HOMEPAGE = "http://sources.redhat.com/docbook-tools/" | ||
5 | SECTION = "console/utils" | ||
6 | PRIORITY = "required" | ||
7 | LICENSE = "GPLv2" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | ||
9 | DEPENDS = "openjade-native sgmlspl-native docbook-dsssl-stylesheets-native docbook-sgml-dtd-3.1-native" | ||
10 | |||
11 | PR = "r0" | ||
12 | |||
13 | SRC_URI = "ftp://sources.redhat.com/pub/docbook-tools/new-trials/SOURCES/docbook-utils-${PV}.tar.gz" | ||
14 | |||
15 | SRC_URI[md5sum] = "6b41b18c365c01f225bc417cf632d81c" | ||
16 | SRC_URI[sha256sum] = "48faab8ee8a7605c9342fb7b906e0815e3cee84a489182af38e8f7c0df2e92e9" | ||
17 | |||
18 | inherit autotools native | ||
19 | |||
20 | do_configure_prepend() { | ||
21 | # Fix hard-coded references to /etc/sgml | ||
22 | sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" bin/jw.in | ||
23 | sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/man/Makefile.am | ||
24 | sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/HTML/Makefile.am | ||
25 | } | ||
26 | |||
27 | do_install() { | ||
28 | install -d ${D}${bindir} | ||
29 | # Install the binaries and a bunch of other commonly used names for them. | ||
30 | for doctype in html ps dvi man pdf rtf tex texi txt | ||
31 | do | ||
32 | install -m 0755 ${S}/bin/docbook2$doctype ${D}${bindir}/ | ||
33 | ln -sf docbook2x-$doctype ${D}${bindir}/db2$doctype | ||
34 | ln -sf docbook2$doctype ${D}${bindir}/db2$doctype | ||
35 | ln -sf docbook2$doctype ${D}${bindir}/docbook-to-$doctype | ||
36 | done | ||
37 | |||
38 | install -m 0755 ${S}/bin/jw ${D}${bindir}/ | ||
39 | for i in backends/dvi backends/html backends/man \ | ||
40 | backends/pdf backends/ps backends/rtf backends/tex \ | ||
41 | backends/texi backends/txt frontends/docbook \ | ||
42 | helpers/docbook2man-spec.pl helpers/docbook2texi-spec.pl \ | ||
43 | docbook-utils.dsl | ||
44 | do | ||
45 | install -d ${D}${datadir}/sgml/docbook/utils-${PV}/`dirname $i` | ||
46 | install ${S}/$i ${D}${datadir}/sgml/docbook/utils-${PV}/$i | ||
47 | done | ||
48 | } | ||