diff options
author | Scott Garman <scott.a.garman@intel.com> | 2011-01-25 15:29:31 -0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-02-01 23:59:35 +0000 |
commit | 942b3b1d37239ef5ecf06f480f8c84b3f4da38a2 (patch) | |
tree | b24a3a7999df149d054d0476d16e152ab599d6f9 /meta/recipes-devtools/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb | |
parent | b2abf1c534bc34d4d4932323aeefa025a82e62c5 (diff) | |
download | poky-942b3b1d37239ef5ecf06f480f8c84b3f4da38a2.tar.gz |
docbook-dsssl-stylesheets: new recipe v1.79
Recipe migrated from OpenEmbedded.
Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta/recipes-devtools/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb')
-rw-r--r-- | meta/recipes-devtools/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb | 52 |
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-devtools/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb b/meta/recipes-devtools/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb new file mode 100644 index 0000000000..92de638783 --- /dev/null +++ b/meta/recipes-devtools/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-native_1.79.bb | |||
@@ -0,0 +1,52 @@ | |||
1 | SUMMARY = "DSSSL stylesheets used to transform SGML and XML DocBook files" | ||
2 | DESCRIPTION = "DSSSL stylesheets used to transform SGML and XML DocBook files" | ||
3 | HOMEPAGE= "http://docbook.sourceforge.net" | ||
4 | # Simple persmissive | ||
5 | LICENSE = "DSSSL" | ||
6 | LIC_FILES_CHKSUM = "file://README;beginline=41;endline=74;md5=875385159b2ee76ecf56136ae7f542d6" | ||
7 | |||
8 | DEPENDS = "sgml-common-native" | ||
9 | |||
10 | PR = "r0" | ||
11 | |||
12 | SRC_URI = "${SOURCEFORGE_MIRROR}/docbook/docbook-dsssl-${PV}.tar.bz2" | ||
13 | |||
14 | SRC_URI[md5sum] = "bc192d23266b9a664ca0aba4a7794c7c" | ||
15 | SRC_URI[sha256sum] = "2f329e120bee9ef42fbdd74ddd60e05e49786c5a7953a0ff4c680ae6bdf0e2bc" | ||
16 | |||
17 | S = "${WORKDIR}/docbook-dsssl-${PV}" | ||
18 | |||
19 | inherit native | ||
20 | |||
21 | SYSROOT_PREPROCESS_FUNCS += "docbook_dssl_stylesheets_native_mangle" | ||
22 | |||
23 | do_install () { | ||
24 | # Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/docbook-dsssl.html | ||
25 | # for details. | ||
26 | install -d ${D}${bindir} | ||
27 | install -m 0755 bin/collateindex.pl ${D}${bindir} | ||
28 | |||
29 | install -d ${D}${datadir}/sgml/docbook/dsssl-stylesheets-${PV} | ||
30 | install -m 0644 catalog ${D}${datadir}/sgml/docbook/dsssl-stylesheets-${PV} | ||
31 | cp -PpRr common ${D}${datadir}/sgml/docbook/dsssl-stylesheets-${PV} | ||
32 | |||
33 | install-catalog --add ${sysconfdir}/sgml/dsssl-docbook-stylesheets.cat \ | ||
34 | ${D}${datadir}/sgml/docbook/dsssl-stylesheets-${PV}/catalog | ||
35 | |||
36 | install-catalog --add ${sysconfdir}/sgml/dsssl-docbook-stylesheets.cat \ | ||
37 | ${D}${datadir}/sgml/docbook/dsssl-stylesheets-${PV}/common/catalog | ||
38 | |||
39 | install-catalog --add ${sysconfdir}/sgml/sgml-docbook.cat \ | ||
40 | ${sysconfdir}/sgml/dsssl-docbook-stylesheets.cat | ||
41 | |||
42 | # Move these to the image directory so they get staged properly. | ||
43 | install -d ${D}${sysconfdir}/sgml | ||
44 | cp ${sysconfdir}/sgml/dsssl-docbook-stylesheets.cat ${D}${sysconfdir}/sgml/ | ||
45 | cp ${sysconfdir}/sgml/sgml-docbook.cat ${D}${sysconfdir}/sgml/ | ||
46 | cp ${sysconfdir}/sgml/catalog ${D}${sysconfdir}/sgml/ | ||
47 | } | ||
48 | |||
49 | docbook_dssl_stylesheets_native_mangle () { | ||
50 | # Remove the image directory path ${D} from the .cat file. | ||
51 | sed -i -e "s|${D}||g" ${SYSROOT_DESTDIR}${sysconfdir}/sgml/dsssl-docbook-stylesheets.cat | ||
52 | } | ||