summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/dnf/dnf_git.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-12-30 19:01:40 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-14 14:42:16 +0000
commitb70f96a17fc13a74c04fd56e34cdc8f84dbf2f69 (patch)
tree4d9b30e8e63f39893d84b40e0f7f64e27c1adec6 /meta/recipes-devtools/dnf/dnf_git.bb
parent374494e746e58d4efa308d0baf52a56ca5b72fb2 (diff)
downloadpoky-b70f96a17fc13a74c04fd56e34cdc8f84dbf2f69.tar.gz
dnf: add a recipe
This is replacing Smart package manager, which is unsupported upstream, and has a growing amount of issues (lack of python 3.x support in particular). We identified dnf as the only feasible replacement. (From OE-Core rev: 2da1f03ad5957fc130f9d4fac30f0048873e9d7c) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/dnf/dnf_git.bb')
-rw-r--r--meta/recipes-devtools/dnf/dnf_git.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-devtools/dnf/dnf_git.bb b/meta/recipes-devtools/dnf/dnf_git.bb
new file mode 100644
index 0000000000..ff22d6f5f0
--- /dev/null
+++ b/meta/recipes-devtools/dnf/dnf_git.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Package manager forked from Yum, using libsolv as a dependency resolver"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
4 file://PACKAGE-LICENSING;md5=bfc29916e11321be06924c4fb096fdcc \
5 "
6
7SRC_URI = "git://github.com/rpm-software-management/dnf.git \
8 file://0028-Use-backports.lzma-not-lzma.patch \
9 file://0029-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
10 file://0030-Run-python-scripts-using-env.patch \
11 file://0001-Do-not-prepend-installroot-to-logdir.patch \
12 file://0001-Do-not-hardcode-etc-and-systemd-unit-directories.patch \
13 file://0001-Corretly-install-tmpfiles.d-configuration.patch \
14 "
15
16PV = "2.0.0+git${SRCPV}"
17SRCREV = "f0093d672d3069cfee8447973ae70ef615fd8886"
18
19S = "${WORKDIR}/git"
20
21inherit cmake gettext bash-completion distutils-base systemd
22
23DEPENDS += "libdnf librepo libcomps python-pygpgme python-iniparse"
24# python 2.x only, drop when moving to python 3.x
25DEPENDS += "python-backports-lzma"
26
27# manpages generation requires http://www.sphinx-doc.org/
28EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR}"
29
30BBCLASSEXTEND = "native nativesdk"
31
32RDEPENDS_${PN}_class-target += "python-core python-codecs python-netclient python-email python-threading python-distutils librepo python-shell python-subprocess libcomps libdnf python-sqlite3 python-compression python-pygpgme python-backports-lzma python-rpm python-iniparse python-json python-importlib python-curses python-argparse"
33
34# Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in
35do_install_append_class-native() {
36 create_wrapper ${D}/${bindir}/dnf-2 \
37 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
38 RPM_NO_CHROOT_FOR_SCRIPTS=1
39}
40
41SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \
42 dnf-automatic-download.service dnf-automatic-download.timer \
43 dnf-automatic-install.service dnf-automatic-install.timer \
44 dnf-automatic-notifyonly.service dnf-automatic-notifyonly.timer \
45"