summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/dnf/dnf_git.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-03-27 16:19:55 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-28 08:43:13 +0100
commit8c1c392ca34da1c64336d0aa2d0a26b9c23d8d39 (patch)
tree37f509b2269d4a37cebcde905b84ec2e52c61d18 /meta/recipes-devtools/dnf/dnf_git.bb
parent3d29214b20433a506a3d59cdc08fc1a9be09a5a0 (diff)
downloadpoky-8c1c392ca34da1c64336d0aa2d0a26b9c23d8d39.tar.gz
dnf: move the entire dnf/rpm4 stack to Python 3
[YOCTO #11180] (From OE-Core rev: bedcdc4cf921b70a8cfb16c6684668d0ac9e1942) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/dnf/dnf_git.bb')
-rw-r--r--meta/recipes-devtools/dnf/dnf_git.bb15
1 files changed, 6 insertions, 9 deletions
diff --git a/meta/recipes-devtools/dnf/dnf_git.bb b/meta/recipes-devtools/dnf/dnf_git.bb
index 3a2cb635e4..7d7f597e5a 100644
--- a/meta/recipes-devtools/dnf/dnf_git.bb
+++ b/meta/recipes-devtools/dnf/dnf_git.bb
@@ -5,7 +5,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 " 5 "
6 6
7SRC_URI = "git://github.com/rpm-software-management/dnf.git \ 7SRC_URI = "git://github.com/rpm-software-management/dnf.git \
8 file://0028-Use-backports.lzma-not-lzma.patch \
9 file://0029-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \ 8 file://0029-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
10 file://0030-Run-python-scripts-using-env.patch \ 9 file://0030-Run-python-scripts-using-env.patch \
11 file://0001-Do-not-prepend-installroot-to-logdir.patch \ 10 file://0001-Do-not-prepend-installroot-to-logdir.patch \
@@ -18,24 +17,22 @@ SRCREV = "f0093d672d3069cfee8447973ae70ef615fd8886"
18 17
19S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
20 19
21inherit cmake gettext bash-completion distutils-base systemd 20inherit cmake gettext bash-completion distutils3-base systemd
22 21
23DEPENDS += "libdnf librepo libcomps python-pygpgme python-iniparse" 22DEPENDS += "libdnf librepo libcomps python3-pygpgme python3-iniparse"
24# python 2.x only, drop when moving to python 3.x
25DEPENDS += "python-backports-lzma"
26 23
27# manpages generation requires http://www.sphinx-doc.org/ 24# manpages generation requires http://www.sphinx-doc.org/
28EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR}" 25EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
29 26
30BBCLASSEXTEND = "native nativesdk" 27BBCLASSEXTEND = "native nativesdk"
31RDEPENDS_${PN}_class-target += "python-core python-codecs python-netclient python-email python-threading python-distutils librepo python-shell python-subprocess libcomps libdnf python-sqlite3 python-compression python-pygpgme python-backports-lzma python-rpm python-iniparse python-json python-importlib python-curses python-argparse" 28RDEPENDS_${PN}_class-target += "python3-core python3-codecs python3-netclient python3-email python3-threading python3-distutils librepo python3-shell python3-subprocess libcomps libdnf python3-sqlite3 python3-compression python3-pygpgme python3-rpm python3-iniparse python3-json python3-importlib python3-curses python3-argparse python3-misc"
32 29
33# Create a symlink called 'dnf' as 'make install' does not do it, but 30# Create a symlink called 'dnf' as 'make install' does not do it, but
34# .spec file in dnf source tree does (and then Fedora and dnf documentation 31# .spec file in dnf source tree does (and then Fedora and dnf documentation
35# says that dnf binary is plain 'dnf'). 32# says that dnf binary is plain 'dnf').
36do_install_append() { 33do_install_append() {
37 ln -s -r ${D}/${bindir}/dnf-2 ${D}/${bindir}/dnf 34 ln -s -r ${D}/${bindir}/dnf-3 ${D}/${bindir}/dnf
38 ln -s -r ${D}/${bindir}/dnf-automatic-2 ${D}/${bindir}/dnf-automatic 35 ln -s -r ${D}/${bindir}/dnf-automatic-3 ${D}/${bindir}/dnf-automatic
39} 36}
40 37
41# Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in 38# Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in