diff options
author | Alexander Kanavin <alex.kanavin@gmail.com> | 2018-11-22 16:41:36 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-11-23 23:35:20 +0000 |
commit | 9ec07073a1b299cc84690427450ec15b5cb1f570 (patch) | |
tree | 4df59f503a990318d8fc0e4f8ff14274772a197a /meta/recipes-devtools/dnf/dnf_4.0.9.bb | |
parent | efebb348c100bbcc22b72056116dd666860d2748 (diff) | |
download | poky-9ec07073a1b299cc84690427450ec15b5cb1f570.tar.gz |
dnf: update to 4.0.9
(From OE-Core rev: 7670325f4b04000255e2fd4ad58a42ab60a70579)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/dnf/dnf_4.0.9.bb')
-rw-r--r-- | meta/recipes-devtools/dnf/dnf_4.0.9.bb | 75 |
1 files changed, 75 insertions, 0 deletions
diff --git a/meta/recipes-devtools/dnf/dnf_4.0.9.bb b/meta/recipes-devtools/dnf/dnf_4.0.9.bb new file mode 100644 index 0000000000..24412fd486 --- /dev/null +++ b/meta/recipes-devtools/dnf/dnf_4.0.9.bb | |||
@@ -0,0 +1,75 @@ | |||
1 | SUMMARY = "Package manager forked from Yum, using libsolv as a dependency resolver" | ||
2 | LICENSE = "GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
4 | file://PACKAGE-LICENSING;md5=4a0548e303dbc77f067335b4d688e745 \ | ||
5 | " | ||
6 | |||
7 | SRC_URI = "git://github.com/rpm-software-management/dnf.git \ | ||
8 | file://0001-Corretly-install-tmpfiles.d-configuration.patch \ | ||
9 | file://0001-Do-not-hardcode-etc-and-systemd-unit-directories.patch \ | ||
10 | file://0005-Do-not-prepend-installroot-to-logdir.patch \ | ||
11 | file://0029-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \ | ||
12 | file://0030-Run-python-scripts-using-env.patch \ | ||
13 | " | ||
14 | |||
15 | SRCREV = "689a4c515738226f3dc85edb2035d23233ff41d8" | ||
16 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)" | ||
17 | |||
18 | S = "${WORKDIR}/git" | ||
19 | |||
20 | inherit cmake gettext bash-completion distutils3-base systemd | ||
21 | |||
22 | DEPENDS += "libdnf librepo libcomps python3-iniparse" | ||
23 | |||
24 | # manpages generation requires http://www.sphinx-doc.org/ | ||
25 | EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3" | ||
26 | |||
27 | BBCLASSEXTEND = "native nativesdk" | ||
28 | |||
29 | RDEPENDS_${PN}_class-target += " \ | ||
30 | python3-core \ | ||
31 | python3-codecs \ | ||
32 | python3-netclient \ | ||
33 | python3-email \ | ||
34 | python3-threading \ | ||
35 | python3-distutils \ | ||
36 | python3-logging \ | ||
37 | python3-fcntl \ | ||
38 | librepo \ | ||
39 | python3-shell \ | ||
40 | libcomps \ | ||
41 | libdnf \ | ||
42 | python3-sqlite3 \ | ||
43 | python3-compression \ | ||
44 | python3-rpm \ | ||
45 | python3-iniparse \ | ||
46 | python3-json \ | ||
47 | python3-curses \ | ||
48 | python3-misc \ | ||
49 | python3-gpg \ | ||
50 | " | ||
51 | |||
52 | RRECOMMENDS_${PN}_class-target += "gnupg" | ||
53 | |||
54 | # Create a symlink called 'dnf' as 'make install' does not do it, but | ||
55 | # .spec file in dnf source tree does (and then Fedora and dnf documentation | ||
56 | # says that dnf binary is plain 'dnf'). | ||
57 | do_install_append() { | ||
58 | lnr ${D}/${bindir}/dnf-3 ${D}/${bindir}/dnf | ||
59 | lnr ${D}/${bindir}/dnf-automatic-3 ${D}/${bindir}/dnf-automatic | ||
60 | } | ||
61 | |||
62 | # Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in | ||
63 | do_install_append_class-native() { | ||
64 | create_wrapper ${D}/${bindir}/dnf \ | ||
65 | RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \ | ||
66 | RPM_NO_CHROOT_FOR_SCRIPTS=1 | ||
67 | } | ||
68 | |||
69 | SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \ | ||
70 | dnf-automatic.service dnf-automatic.timer \ | ||
71 | dnf-automatic-download.service dnf-automatic-download.timer \ | ||
72 | dnf-automatic-install.service dnf-automatic-install.timer \ | ||
73 | dnf-automatic-notifyonly.service dnf-automatic-notifyonly.timer \ | ||
74 | " | ||
75 | SYSTEMD_AUTO_ENABLE ?= "disable" | ||