diff options
author | Alexander Kanavin <alexander.kanavin@linux.intel.com> | 2017-06-21 15:58:20 +0300 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-06-23 11:44:14 +0100 |
commit | f74fd6dbcc664b4f902e5c88cee835f9877dde45 (patch) | |
tree | c0d701cca14c52c3231d93eca1c0804f2c90b4f2 /meta/recipes-devtools/dnf/dnf_2.5.1.bb | |
parent | 13ba631b05342c6d5044fb80c247ed5ea051782d (diff) | |
download | poky-f74fd6dbcc664b4f902e5c88cee835f9877dde45.tar.gz |
dnf: update to 2.5.1
Drop 0001-Revert-proper-check-of-releasever-when-using-install.patch
as the problem has been solved upstream.
Add 0001-Move-releasever-check-after-the-etc-dnf-vars-substit.patch,
as the warning for missing releasever is issued prematurely in our case.
(From OE-Core rev: 68b01f9fe239aa224daa8dc901fa3cf0350261c0)
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/dnf/dnf_2.5.1.bb')
-rw-r--r-- | meta/recipes-devtools/dnf/dnf_2.5.1.bb | 50 |
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-devtools/dnf/dnf_2.5.1.bb b/meta/recipes-devtools/dnf/dnf_2.5.1.bb new file mode 100644 index 0000000000..cdc2a8549f --- /dev/null +++ b/meta/recipes-devtools/dnf/dnf_2.5.1.bb | |||
@@ -0,0 +1,50 @@ | |||
1 | SUMMARY = "Package manager forked from Yum, using libsolv as a dependency resolver" | ||
2 | LICENSE = "GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
4 | file://PACKAGE-LICENSING;md5=bfc29916e11321be06924c4fb096fdcc \ | ||
5 | " | ||
6 | |||
7 | SRC_URI = "git://github.com/rpm-software-management/dnf.git \ | ||
8 | file://0001-Move-releasever-check-after-the-etc-dnf-vars-substit.patch \ | ||
9 | file://0029-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \ | ||
10 | file://0030-Run-python-scripts-using-env.patch \ | ||
11 | file://0001-Do-not-prepend-installroot-to-logdir.patch \ | ||
12 | file://0001-Do-not-hardcode-etc-and-systemd-unit-directories.patch \ | ||
13 | file://0001-Corretly-install-tmpfiles.d-configuration.patch \ | ||
14 | " | ||
15 | |||
16 | SRCREV = "32e6ffdc8902b868cd8f98f9c399c98c9de0c7b8" | ||
17 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)" | ||
18 | |||
19 | S = "${WORKDIR}/git" | ||
20 | |||
21 | inherit cmake gettext bash-completion distutils3-base systemd | ||
22 | |||
23 | DEPENDS += "libdnf librepo libcomps python3-iniparse" | ||
24 | |||
25 | # manpages generation requires http://www.sphinx-doc.org/ | ||
26 | EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3" | ||
27 | |||
28 | BBCLASSEXTEND = "native nativesdk" | ||
29 | RDEPENDS_${PN}_class-target += "python3-core python3-codecs python3-netclient python3-email python3-threading python3-distutils librepo python3-shell python3-subprocess libcomps libdnf python3-sqlite3 python3-compression python3-rpm python3-iniparse python3-json python3-importlib python3-curses python3-argparse python3-misc python3-gpg" | ||
30 | |||
31 | # Create a symlink called 'dnf' as 'make install' does not do it, but | ||
32 | # .spec file in dnf source tree does (and then Fedora and dnf documentation | ||
33 | # says that dnf binary is plain 'dnf'). | ||
34 | do_install_append() { | ||
35 | lnr ${D}/${bindir}/dnf-3 ${D}/${bindir}/dnf | ||
36 | lnr ${D}/${bindir}/dnf-automatic-3 ${D}/${bindir}/dnf-automatic | ||
37 | } | ||
38 | |||
39 | # Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in | ||
40 | do_install_append_class-native() { | ||
41 | create_wrapper ${D}/${bindir}/dnf \ | ||
42 | RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \ | ||
43 | RPM_NO_CHROOT_FOR_SCRIPTS=1 | ||
44 | } | ||
45 | |||
46 | SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \ | ||
47 | dnf-automatic-download.service dnf-automatic-download.timer \ | ||
48 | dnf-automatic-install.service dnf-automatic-install.timer \ | ||
49 | dnf-automatic-notifyonly.service dnf-automatic-notifyonly.timer \ | ||
50 | " | ||