summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/distcc/distcc_3.4.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-05-20 07:53:51 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-21 15:18:23 +0100
commit206b26ecd40d5bfb37003ac42ce46f44b506098f (patch)
treebeabf8239362d1dda45006220a306a834abc1349 /meta/recipes-devtools/distcc/distcc_3.4.bb
parent9f0cbdf2c145ff8f45a4ae5dd8f82c553980b9ef (diff)
downloadpoky-206b26ecd40d5bfb37003ac42ce46f44b506098f.tar.gz
distcc: upgrade 3.3.5 -> 3.4
(From OE-Core rev: 572d446cca38d564e462ccc5d8f7bcf1648433b0) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/distcc/distcc_3.4.bb')
-rw-r--r--meta/recipes-devtools/distcc/distcc_3.4.bb88
1 files changed, 88 insertions, 0 deletions
diff --git a/meta/recipes-devtools/distcc/distcc_3.4.bb b/meta/recipes-devtools/distcc/distcc_3.4.bb
new file mode 100644
index 0000000000..3bab6d53eb
--- /dev/null
+++ b/meta/recipes-devtools/distcc/distcc_3.4.bb
@@ -0,0 +1,88 @@
1SUMMARY = "A parallel build system"
2DESCRIPTION = "distcc is a parallel build system that distributes \
3compilation of C/C++/ObjC code across machines on a network."
4HOMEPAGE = "https://github.com/distcc/distcc"
5SECTION = "devel"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
8
9DEPENDS = "avahi binutils"
10
11PACKAGECONFIG ??= "popt"
12PACKAGECONFIG[gtk] = "--with-gtk,--without-gtk --without-gnome,gtk+"
13# use system popt by default
14PACKAGECONFIG[popt] = "--without-included-popt,--with-included-popt,popt"
15
16RRECOMMENDS_${PN}-server = "avahi-daemon"
17
18SRC_URI = "git://github.com/distcc/distcc.git \
19 file://default \
20 file://distcc \
21 file://distcc.service \
22 "
23SRCREV = "50d821efe99cae82c05be0a4ab3b4035ef0d3883"
24S = "${WORKDIR}/git"
25UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
26
27inherit autotools pkgconfig update-rc.d useradd systemd
28
29ASNEEDED = ""
30
31EXTRA_OECONF += "--disable-Werror PYTHON='' --disable-pump-mode"
32
33PACKAGE_BEFORE_PN = "${PN}-distmon-gnome ${PN}-server"
34
35USERADD_PACKAGES = "${PN}-server"
36USERADD_PARAM_${PN}-server = "--system \
37 --home /dev/null \
38 --no-create-home \
39 --gid nogroup \
40 distcc"
41
42UPDATERCPN = "${PN}-server"
43INITSCRIPT_NAME = "distcc"
44
45SYSTEMD_PACKAGES = "${PN}-server"
46SYSTEMD_SERVICE_${PN}-server = "distcc.service"
47
48do_install() {
49 # Improve reproducibility: compress w/o timestamps
50 oe_runmake 'DESTDIR=${D}' "GZIP_BIN=gzip -n" install
51 install -d ${D}${sysconfdir}/init.d/
52 install -d ${D}${sysconfdir}/default
53 install -m 0755 ${WORKDIR}/distcc ${D}${sysconfdir}/init.d/
54 install -m 0755 ${WORKDIR}/default ${D}${sysconfdir}/default/distcc
55 install -d ${D}${systemd_unitdir}/system/
56 install -m 0644 ${WORKDIR}/distcc.service ${D}${systemd_unitdir}/system
57 sed -i -e 's,@BINDIR@,${bindir},g' ${D}${systemd_unitdir}/system/distcc.service
58}
59
60FILES_${PN}-server = "${sysconfdir} \
61 ${bindir}/distccd \
62 ${sbindir}"
63FILES_${PN}-distmon-gnome = "${bindir}/distccmon-gnome \
64 ${datadir}/applications \
65 ${datadir}/pixmaps"
66
67#
68# distcc upstream dropped the 3.2 branch which we reference in older project releases
69# the revisions are there, just the branch is not. In order to be able to continue
70# to build those old releases, adjust any mirror tarball to contain the missing branch
71#
72fixup_distcc_mirror_tarball () {
73 TBALL=${DL_DIR}/git2_github.com.distcc.distcc.git.tar.gz
74 if [ -f $TBALL ]; then
75 TDIR=`mktemp -d`
76 cd $TDIR
77 tar -xzf $TBALL
78 set +e
79 git rev-parse --verify 3.2
80 if [ "$?" != "0" ]; then
81 git branch 3.2 d8b18df3e9dcbe4f092bed565835d3975e99432c
82 tar -czf $TBALL *
83 fi
84 set -e
85 rm -rf $TDIR/*
86 fi
87}
88do_fetch[postfuncs] += "fixup_distcc_mirror_tarball"