summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/distcc/distcc_3.3.3.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-09-20 12:28:03 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-27 13:02:16 +0100
commit4503c1c411ca0739fd3f9c19b9da9788a7e9eaf9 (patch)
tree0cca9973d509625f23fefb6809a621ac96fe120b /meta/recipes-devtools/distcc/distcc_3.3.3.bb
parent56da8174e7cf1de7c17cfb7b3d62ec36841f5520 (diff)
downloadpoky-4503c1c411ca0739fd3f9c19b9da9788a7e9eaf9.tar.gz
distcc: clean up the UI install logic
Remove the local copy of the desktop file, instead apply a patch from upstream to fix the file. This also fixes the install paths, so update the recipe. Remove glibc-specific installation as this was due to uclibc failures. Refresh and submit upstream the out-of-tree build fix. (From OE-Core rev: f69cb86f4c15497c6324a0e8063f86cc31cfe7aa) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/distcc/distcc_3.3.3.bb')
-rw-r--r--meta/recipes-devtools/distcc/distcc_3.3.3.bb13
1 files changed, 5 insertions, 8 deletions
diff --git a/meta/recipes-devtools/distcc/distcc_3.3.3.bb b/meta/recipes-devtools/distcc/distcc_3.3.3.bb
index 7942debec9..d8ad498f2b 100644
--- a/meta/recipes-devtools/distcc/distcc_3.3.3.bb
+++ b/meta/recipes-devtools/distcc/distcc_3.3.3.bb
@@ -15,9 +15,9 @@ PACKAGECONFIG[popt] = "--without-included-popt,--with-included-popt,popt"
15RRECOMMENDS_${PN} = "avahi-daemon" 15RRECOMMENDS_${PN} = "avahi-daemon"
16 16
17SRC_URI = "git://github.com/distcc/distcc.git \ 17SRC_URI = "git://github.com/distcc/distcc.git \
18 file://fix-gnome.patch \
18 file://separatebuilddir.patch \ 19 file://separatebuilddir.patch \
19 file://default \ 20 file://default \
20 file://distccmon-gnome.desktop \
21 file://distcc \ 21 file://distcc \
22 file://distcc.service" 22 file://distcc.service"
23SRCREV = "4cde9bcfbda589abd842e3bbc652ce369085eaae" 23SRCREV = "4cde9bcfbda589abd842e3bbc652ce369085eaae"
@@ -51,13 +51,8 @@ do_install() {
51 install -d ${D}${systemd_unitdir}/system/ 51 install -d ${D}${systemd_unitdir}/system/
52 install -m 0644 ${WORKDIR}/distcc.service ${D}${systemd_unitdir}/system 52 install -m 0644 ${WORKDIR}/distcc.service ${D}${systemd_unitdir}/system
53 sed -i -e 's,@BINDIR@,${bindir},g' ${D}${systemd_unitdir}/system/distcc.service 53 sed -i -e 's,@BINDIR@,${bindir},g' ${D}${systemd_unitdir}/system/distcc.service
54 ${DESKTOPINSTALL}
55}
56DESKTOPINSTALL = ""
57DESKTOPINSTALL_libc-glibc () {
58 install -d ${D}${datadir}/distcc/
59 install -m 0644 ${WORKDIR}/distccmon-gnome.desktop ${D}${datadir}/distcc/
60} 54}
55
61PACKAGES += "distcc-distmon-gnome" 56PACKAGES += "distcc-distmon-gnome"
62 57
63FILES_${PN} = " ${sysconfdir} \ 58FILES_${PN} = " ${sysconfdir} \
@@ -67,8 +62,10 @@ FILES_${PN} = " ${sysconfdir} \
67 ${bindir}/distccmon-text \ 62 ${bindir}/distccmon-text \
68 ${sbindir}/update-distcc-symlinks \ 63 ${sbindir}/update-distcc-symlinks \
69 ${systemd_unitdir}/system/distcc.service" 64 ${systemd_unitdir}/system/distcc.service"
65
70FILES_distcc-distmon-gnome = " ${bindir}/distccmon-gnome \ 66FILES_distcc-distmon-gnome = " ${bindir}/distccmon-gnome \
71 ${datadir}/distcc" 67 ${datadir}/applications \
68 ${datadir}/pixmaps"
72 69
73 70
74# 71#