summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/distcc/distcc_3.1.bb
diff options
context:
space:
mode:
authorBogdan Marinescu <bogdan.a.marinescu@intel.com>2013-02-01 11:29:03 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-04 13:18:25 +0000
commit691a9908f54cfc213ee1fb3ffa690b2f30fb981d (patch)
tree32f6254992f8737789bfac760ca57aac1d6cb668 /meta/recipes-devtools/distcc/distcc_3.1.bb
parent57bbb7d6f4058ac41f37406046e684dfd2bd8ae0 (diff)
downloadpoky-691a9908f54cfc213ee1fb3ffa690b2f30fb981d.tar.gz
distcc: updated to version 3.1
Added two new flags to the configure script: --disable-Werror: don't treat all warnings all errors (which breaks compilation). PYTHON=/dev/null: this prevents distcc from detecting the host Python and trying to build its include server using the host Python. This disables the include server completely. If the include server is needed, that should be the object of another patch (and would introduce a dependency on python for distcc). The 'distcc-avahi' and 'makefile-param-order' patches are not needed anymore, as they were merged upstream. (From OE-Core rev: 3f33a6ecd9f1703381e175d688bdfce291ffdc8a) Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/distcc/distcc_3.1.bb')
-rw-r--r--meta/recipes-devtools/distcc/distcc_3.1.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta/recipes-devtools/distcc/distcc_3.1.bb b/meta/recipes-devtools/distcc/distcc_3.1.bb
new file mode 100644
index 0000000000..eeda054c74
--- /dev/null
+++ b/meta/recipes-devtools/distcc/distcc_3.1.bb
@@ -0,0 +1,64 @@
1SUMMARY = "A parallel build system"
2DESCRIPTION = "distcc is a parallel build system that distributes \
3compilation of C/C++/ObjC code across machines on a network."
4SECTION = "devel"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7PR = "r0"
8
9DEPENDS = "avahi"
10
11GTKCONFIG = "gtk"
12GTKCONFIG_libc-uclibc = ""
13
14PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', '${GTKCONFIG}', '', d)}"
15PACKAGECONFIG[gtk] = "--with-gtk,--without-gtk --without-gnome,gtk+"
16
17RRECOMMENDS_${PN} = "avahi-daemon"
18
19SRC_URI = "http://distcc.googlecode.com/files/${BPN}-${PV}.tar.bz2 \
20 file://default \
21 file://distccmon-gnome.desktop \
22 file://distcc"
23
24SRC_URI[md5sum] = "a1a9d3853df7133669fffec2a9aab9f3"
25SRC_URI[sha256sum] = "f55dbafd76bed3ce57e1bbcdab1329227808890d90f4c724fcd2d53f934ddd89"
26
27inherit autotools pkgconfig update-rc.d useradd
28
29EXTRA_OECONF += "--disable-Werror PYTHON=/dev/null"
30
31USERADD_PACKAGES = "${PN}"
32USERADD_PARAM_${PN} = "--system \
33 --home /dev/null \
34 --no-create-home \
35 --gid nogroup \
36 distcc"
37
38INITSCRIPT_NAME = "distcc"
39
40do_install_append() {
41 install -d ${D}${sysconfdir}/init.d/
42 install -d ${D}${sysconfdir}/default
43 install -m 0755 ${WORKDIR}/distcc ${D}${sysconfdir}/init.d/
44 install -m 0755 ${WORKDIR}/default ${D}${sysconfdir}/default/distcc
45 ${DESKTOPINSTALL}
46}
47DESKTOPINSTALL = ""
48DESKTOPINSTALL_libc-glibc () {
49 install -d ${D}${datadir}/distcc/
50 install -m 0644 ${WORKDIR}/distccmon-gnome.desktop ${D}${datadir}/distcc/
51}
52PACKAGES += "distcc-distmon-gnome"
53
54FILES_${PN} = " ${sysconfdir} \
55 ${bindir}/distcc \
56 ${bindir}/lsdistcc \
57 ${bindir}/distccd \
58 ${bindir}/distccmon-text"
59FILES_distcc-distmon-gnome = " ${bindir}/distccmon-gnome \
60 ${datadir}/distcc"
61
62pkg_postrm_${PN} () {
63 deluser distcc || true
64}