summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/diffstat/diffstat_1.59.bb
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-07-16 16:52:05 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-19 00:09:01 +0100
commit478dbd3f007ec4c2dc44d19c4344c812726d8d4a (patch)
tree9f8acda3ac4f76c376281adec3f0da78848882e6 /meta/recipes-devtools/diffstat/diffstat_1.59.bb
parent01e556cd0dad84a926c6ee15587a287abaa1e6db (diff)
downloadpoky-478dbd3f007ec4c2dc44d19c4344c812726d8d4a.tar.gz
diffstat: update to version 1.59
Remove unneeded patches, since they're included in new version. (From OE-Core rev: 0e2d98bc17d4f3b80926f9a86006010ea6907a74) Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/diffstat/diffstat_1.59.bb')
-rw-r--r--meta/recipes-devtools/diffstat/diffstat_1.59.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/diffstat/diffstat_1.59.bb b/meta/recipes-devtools/diffstat/diffstat_1.59.bb
new file mode 100644
index 0000000000..f599622b3e
--- /dev/null
+++ b/meta/recipes-devtools/diffstat/diffstat_1.59.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Tool to produce a statistics based on a diff"
2DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \
3the insertions, deletions, and modifications per-file. It is useful for \
4reviewing large, complex patch files."
5HOMEPAGE = "http://invisible-island.net/diffstat/"
6SECTION = "devel"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://install-sh;endline=42;md5=b3549726c1022bee09c174c72a0ca4a5"
9
10SRC_URI = "ftp://invisible-island.net/diffstat/diffstat-${PV}.tgz \
11 file://run-ptest \
12"
13
14SRC_URI[md5sum] = "1dc7bc48ce846a0686a1af0d091ff8fb"
15SRC_URI[sha256sum] = "267d1441b8889cbefbb7ca7dfd4a17f6c8bc73bc114904c74ecad945a3dbf270"
16
17S = "${WORKDIR}/diffstat-${PV}"
18
19inherit autotools gettext ptest
20
21do_configure () {
22 if [ ! -e ${S}/acinclude.m4 ]; then
23 mv ${S}/aclocal.m4 ${S}/acinclude.m4
24 fi
25 autotools_do_configure
26}
27
28do_install_ptest() {
29 cp -r ${S}/testing ${D}${PTEST_PATH}
30}