summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cve-check-tool/cve-check-tool_5.6.4.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2017-02-09 21:38:33 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-15 09:29:56 -0800
commitd887c24d5af0f570a259985fa99af5c56158fcfa (patch)
treeae5d59972c956d573f5795615d29ba22b3b0e204 /meta/recipes-devtools/cve-check-tool/cve-check-tool_5.6.4.bb
parentea616d122676e7d5bbf606b7dbfa8f62c63d4a27 (diff)
downloadpoky-d887c24d5af0f570a259985fa99af5c56158fcfa.tar.gz
cve-check-tool: Use CA cert bundle in correct sysroot
Native libcurl looks for CA certs in the wrong place by default. * Add patch that allows overriding the default CA certificate location. Patch is originally from meta-security-isafw. * Use the new --cacert to set the correct CA bundle path (From OE-Core rev: 73bd11d5190a072064128cc13b4537154d07b129) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cve-check-tool/cve-check-tool_5.6.4.bb')
-rw-r--r--meta/recipes-devtools/cve-check-tool/cve-check-tool_5.6.4.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-devtools/cve-check-tool/cve-check-tool_5.6.4.bb b/meta/recipes-devtools/cve-check-tool/cve-check-tool_5.6.4.bb
index c78af6728c..fcd3182931 100644
--- a/meta/recipes-devtools/cve-check-tool/cve-check-tool_5.6.4.bb
+++ b/meta/recipes-devtools/cve-check-tool/cve-check-tool_5.6.4.bb
@@ -9,6 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e8c1458438ead3c34974bc0be3a03ed6"
9SRC_URI = "https://github.com/ikeydoherty/${BPN}/releases/download/v${PV}/${BP}.tar.xz \ 9SRC_URI = "https://github.com/ikeydoherty/${BPN}/releases/download/v${PV}/${BP}.tar.xz \
10 file://check-for-malloc_trim-before-using-it.patch \ 10 file://check-for-malloc_trim-before-using-it.patch \
11 file://0001-print-progress-in-percent-when-downloading-CVE-db.patch \ 11 file://0001-print-progress-in-percent-when-downloading-CVE-db.patch \
12 file://0001-curl-allow-overriding-default-CA-certificate-file.patch \
12 " 13 "
13 14
14SRC_URI[md5sum] = "c5f4247140fc9be3bf41491d31a34155" 15SRC_URI[md5sum] = "c5f4247140fc9be3bf41491d31a34155"
@@ -39,7 +40,8 @@ do_populate_cve_db() {
39 [ -z "${cve_file}" ] && cve_file="${TMPDIR}/cve_check" 40 [ -z "${cve_file}" ] && cve_file="${TMPDIR}/cve_check"
40 41
41 bbdebug 2 "Updating cve-check-tool database located in $cve_dir" 42 bbdebug 2 "Updating cve-check-tool database located in $cve_dir"
42 if cve-check-update -d "$cve_dir" ; then 43 # --cacert works around curl-native not finding the CA bundle
44 if cve-check-update --cacert ${sysconfdir}/ssl/certs/ca-certificates.crt -d "$cve_dir" ; then
43 printf "CVE database was updated on %s UTC\n\n" "$(LANG=C date --utc +'%F %T')" > "$cve_file" 45 printf "CVE database was updated on %s UTC\n\n" "$(LANG=C date --utc +'%F %T')" > "$cve_file"
44 else 46 else
45 bbwarn "Error in executing cve-check-update" 47 bbwarn "Error in executing cve-check-update"