summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/createrepo-c/createrepo-c_1.1.4.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-08-20 14:51:22 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-08-21 21:51:49 +0100
commit7a668c5043c5d6afdef9e280217a973db6db9dec (patch)
treec83a638e5d949fb28a299792fc762af2a1e85119 /meta/recipes-devtools/createrepo-c/createrepo-c_1.1.4.bb
parent2ff9d40ccb493967151bfed6aed889de45bdd464 (diff)
downloadpoky-7a668c5043c5d6afdef9e280217a973db6db9dec.tar.gz
createrepo-c: upgrade 1.1.3 -> 1.1.4
(From OE-Core rev: 945c6e18b00000ce323037f93c8edb577d8f1533) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/createrepo-c/createrepo-c_1.1.4.bb')
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c_1.1.4.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_1.1.4.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_1.1.4.bb
new file mode 100644
index 0000000000..0a37c76187
--- /dev/null
+++ b/meta/recipes-devtools/createrepo-c/createrepo-c_1.1.4.bb
@@ -0,0 +1,41 @@
1SUMMARY = "C implementation of createrepo."
2HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki"
3
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = "git://github.com/rpm-software-management/createrepo_c;branch=master;protocol=https \
8 file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
9 file://0001-include-rpm-rpmstring.h.patch \
10 "
11
12SRCREV = "a5a8990ff84b7977218976ea14c703330fb52875"
13
14S = "${WORKDIR}/git"
15
16DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm"
17DEPENDS:append:class-native = " file-replacement-native"
18
19inherit cmake pkgconfig bash-completion setuptools3-base
20
21EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DWITH_ZCHUNK=OFF -DENABLE_DRPM=OFF -DWITH_LIBMODULEMD=OFF"
22
23BBCLASSEXTEND = "native nativesdk"
24
25# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
26do_install:append:class-native() {
27 create_wrapper ${D}/${bindir}/createrepo_c \
28 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
29 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc
30 create_wrapper ${D}/${bindir}/modifyrepo_c \
31 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc
32}
33
34do_install:append:class-nativesdk() {
35 create_wrapper ${D}/${bindir}/createrepo_c \
36 RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
37 MAGIC=${datadir}/misc/magic.mgc
38 create_wrapper ${D}/${bindir}/modifyrepo_c \
39 MAGIC=${datadir}/misc/magic.mgc
40 rm -rf ${D}/etc
41}