summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.6.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-10-19 17:33:44 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-23 17:42:25 +0100
commit09d91a0e62cd55a29b5d677209c59039cd90f88e (patch)
tree20ae45a194a7ec0a5cf29e6c25f223c5dc88142f /meta/recipes-devtools/createrepo-c/createrepo-c_0.17.6.bb
parent75aca0d641b80c7d09e8fc3a8f7d6fc06aca76ef (diff)
downloadpoky-09d91a0e62cd55a29b5d677209c59039cd90f88e.tar.gz
createrepo-c: upgrade 0.17.5 -> 0.17.6
(From OE-Core rev: 1b6253bcc2a7915d881e16462f652b2e3b7d30f9) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/createrepo-c/createrepo-c_0.17.6.bb')
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c_0.17.6.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.6.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.6.bb
new file mode 100644
index 0000000000..f9fa8f52d3
--- /dev/null
+++ b/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.6.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "C implementation of createrepo."
2HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = "git://github.com/rpm-software-management/createrepo_c \
8 file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
9 "
10
11SRCREV = "d764fe9b386aa8da1aca58b9bc3dc061f52e8f28"
12
13S = "${WORKDIR}/git"
14
15DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm"
16DEPENDS:append:class-native = " file-replacement-native"
17
18inherit cmake pkgconfig bash-completion distutils3-base
19
20EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DWITH_ZCHUNK=OFF -DENABLE_DRPM=OFF -DWITH_LIBMODULEMD=OFF"
21
22BBCLASSEXTEND = "native nativesdk"
23
24# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
25do_install:append:class-native() {
26 create_wrapper ${D}/${bindir}/createrepo_c \
27 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
28 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc
29 create_wrapper ${D}/${bindir}/modifyrepo_c \
30 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc
31}
32
33do_install:append:class-nativesdk() {
34 create_wrapper ${D}/${bindir}/createrepo_c \
35 RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
36 MAGIC=${datadir}/misc/magic.mgc
37 create_wrapper ${D}/${bindir}/modifyrepo_c \
38 MAGIC=${datadir}/misc/magic.mgc
39 rm -rf ${D}/etc
40}