diff options
author | Alexander Kanavin <alex.kanavin@gmail.com> | 2021-07-14 14:25:54 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2021-07-16 21:23:43 +0100 |
commit | bd459927c106967f2b3a4f7ed1633ddb11f2e67d (patch) | |
tree | cb2154b85838b8c922844df17f2ad784d779db1f /meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb | |
parent | 14fb2efa7baa2093d7c50e51b5d516d723129f8a (diff) | |
download | poky-bd459927c106967f2b3a4f7ed1633ddb11f2e67d.tar.gz |
createrepo-c: upgrade 0.17.3 -> 0.17.4
(From OE-Core rev: ed220fb35e828f9aa13af8db1ae1b2adf5f18e72)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb')
-rw-r--r-- | meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb | 40 |
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb new file mode 100644 index 0000000000..206c27c04f --- /dev/null +++ b/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | DESCRIPTION = "C implementation of createrepo." | ||
2 | HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki" | ||
3 | |||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
6 | |||
7 | SRC_URI = "git://github.com/rpm-software-management/createrepo_c \ | ||
8 | file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \ | ||
9 | " | ||
10 | |||
11 | SRCREV = "cb74969736bdea86465e85feeceb895ff7a42610" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm" | ||
16 | DEPENDS_append_class-native = " file-replacement-native" | ||
17 | |||
18 | inherit cmake pkgconfig bash-completion distutils3-base | ||
19 | |||
20 | EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DWITH_ZCHUNK=OFF -DENABLE_DRPM=OFF -DWITH_LIBMODULEMD=OFF" | ||
21 | |||
22 | BBCLASSEXTEND = "native nativesdk" | ||
23 | |||
24 | # Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in | ||
25 | do_install_append_class-native() { | ||
26 | create_wrapper ${D}/${bindir}/createrepo_c \ | ||
27 | RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \ | ||
28 | MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc | ||
29 | create_wrapper ${D}/${bindir}/modifyrepo_c \ | ||
30 | MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc | ||
31 | } | ||
32 | |||
33 | do_install_append_class-nativesdk() { | ||
34 | create_wrapper ${D}/${bindir}/createrepo_c \ | ||
35 | RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \ | ||
36 | MAGIC=${SDKPATHNATIVE}${datadir}/misc/magic.mgc | ||
37 | create_wrapper ${D}/${bindir}/modifyrepo_c \ | ||
38 | MAGIC=${SDKPATHNATIVE}${datadir}/misc/magic.mgc | ||
39 | rm -rf ${D}/etc | ||
40 | } | ||