summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake_3.7.0.bb
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2016-12-14 21:13:04 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-16 10:23:23 +0000
commitc4e2c59088765d1f1de7ec57cde91980f887c2ff (patch)
treea2fda8ac5916fb59a711e9220c2177008cca9347 /meta/recipes-devtools/cmake/cmake_3.7.0.bb
parentd5e67725ac11e3296cad104470931ffa16824b90 (diff)
downloadpoky-c4e2c59088765d1f1de7ec57cde91980f887c2ff.tar.gz
meta: remove True option to getVar calls
getVar() now defaults to expanding by default, thus remove the True option from getVar() calls with a regex search and replace. Search made with the following regex: getVar ?\(( ?[^,()]*), True\) (From OE-Core rev: 7c552996597faaee2fbee185b250c0ee30ea3b5f) Signed-off-by: Joshua Lock <joshua.g.lock@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake_3.7.0.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake_3.7.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/cmake/cmake_3.7.0.bb b/meta/recipes-devtools/cmake/cmake_3.7.0.bb
index 58c6615680..787f33c02b 100644
--- a/meta/recipes-devtools/cmake/cmake_3.7.0.bb
+++ b/meta/recipes-devtools/cmake/cmake_3.7.0.bb
@@ -10,8 +10,8 @@ SRC_URI_append_class-nativesdk = " \
10 10
11# Strip ${prefix} from ${docdir}, set result into docdir_stripped 11# Strip ${prefix} from ${docdir}, set result into docdir_stripped
12python () { 12python () {
13 prefix=d.getVar("prefix", True) 13 prefix=d.getVar("prefix")
14 docdir=d.getVar("docdir", True) 14 docdir=d.getVar("docdir")
15 15
16 if not docdir.startswith(prefix): 16 if not docdir.startswith(prefix):
17 bb.fatal('docdir must contain prefix as its prefix') 17 bb.fatal('docdir must contain prefix as its prefix')