diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-11-09 15:00:01 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-11-10 11:51:19 +0000 |
commit | c8dee9b92dfd545852ecac8dc2adfc95ac02e957 (patch) | |
tree | 5f1b86954646a0f3bb914407994388a6a4346769 /meta/recipes-devtools/cmake/cmake_2.8.5.bb | |
parent | 5d3860f4a8abb8e95442b04f8b84a333af362fcd (diff) | |
download | poky-c8dee9b92dfd545852ecac8dc2adfc95ac02e957.tar.gz |
Convert to use direct access to the data store (instead of bb.data.*Var*())
This is the result of running the following over the metadata:
sed \
-e 's:bb.data.\(setVar([^,()]*,[^,()]*\), *\([^ )]*\) *):\2.\1):g' \
-e 's:bb.data.\(setVarFlag([^,()]*,[^,()]*,[^,()]*\), *\([^) ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,()]*\), *\([^(), ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,()]*,[^,()]*\), *\([^(), ]*\) *,\([^)]*\)):\2.\1,\3):g' \
-e 's:bb.data.\(getVarFlag([^,()]*,[^,()]*\), *\([^() ]*\) *):\2.\1):g' \
-e 's:bb.data.\(getVar([^,()]*\), *\([^) ]*\) *):\2.\1):g' \
-i `grep -ril bb.data *`
(From OE-Core rev: b22831fd63164c4db9c0b72934d7d734a6585251)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake_2.8.5.bb')
-rw-r--r-- | meta/recipes-devtools/cmake/cmake_2.8.5.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/cmake/cmake_2.8.5.bb b/meta/recipes-devtools/cmake/cmake_2.8.5.bb index 8e040728c9..3e2a218385 100644 --- a/meta/recipes-devtools/cmake/cmake_2.8.5.bb +++ b/meta/recipes-devtools/cmake/cmake_2.8.5.bb | |||
@@ -13,8 +13,8 @@ SRC_URI[sha256sum] = "5e18bff75f01656c64f553412a8905527e1b85efaf3163c6fb81ea5aac | |||
13 | 13 | ||
14 | # Strip ${prefix} from ${docdir}, set result into docdir_stripped | 14 | # Strip ${prefix} from ${docdir}, set result into docdir_stripped |
15 | python () { | 15 | python () { |
16 | prefix=bb.data.getVar("prefix", d, 1) | 16 | prefix=d.getVar("prefix", 1) |
17 | docdir=bb.data.getVar("docdir", d, 1) | 17 | docdir=d.getVar("docdir", 1) |
18 | 18 | ||
19 | if not docdir.startswith(prefix): | 19 | if not docdir.startswith(prefix): |
20 | raise bb.build.FuncFailed('docdir must contain prefix as its prefix') | 20 | raise bb.build.FuncFailed('docdir must contain prefix as its prefix') |
@@ -23,7 +23,7 @@ python () { | |||
23 | if len(docdir_stripped) > 0 and docdir_stripped[0] == '/': | 23 | if len(docdir_stripped) > 0 and docdir_stripped[0] == '/': |
24 | docdir_stripped = docdir_stripped[1:] | 24 | docdir_stripped = docdir_stripped[1:] |
25 | 25 | ||
26 | bb.data.setVar("docdir_stripped", docdir_stripped, d) | 26 | d.setVar("docdir_stripped", docdir_stripped) |
27 | } | 27 | } |
28 | 28 | ||
29 | EXTRA_OECMAKE=" \ | 29 | EXTRA_OECMAKE=" \ |