summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake_2.8.12.2.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-devtools/cmake/cmake_2.8.12.2.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake_2.8.12.2.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake_2.8.12.2.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake_2.8.12.2.bb b/meta/recipes-devtools/cmake/cmake_2.8.12.2.bb
new file mode 100644
index 0000000000..30ae61ed8a
--- /dev/null
+++ b/meta/recipes-devtools/cmake/cmake_2.8.12.2.bb
@@ -0,0 +1,38 @@
1require cmake.inc
2
3inherit cmake
4
5DEPENDS += "curl expat zlib libarchive"
6
7SRC_URI += "file://dont-run-cross-binaries.patch"
8
9SRC_URI[md5sum] = "17c6513483d23590cbce6957ec6d1e66"
10SRC_URI[sha256sum] = "8c6574e9afabcb9fc66f463bb1f2f051958d86c85c37fccf067eb1a44a120e5e"
11
12# Strip ${prefix} from ${docdir}, set result into docdir_stripped
13python () {
14 prefix=d.getVar("prefix", True)
15 docdir=d.getVar("docdir", True)
16
17 if not docdir.startswith(prefix):
18 raise bb.build.FuncFailed('docdir must contain prefix as its prefix')
19
20 docdir_stripped = docdir[len(prefix):]
21 if len(docdir_stripped) > 0 and docdir_stripped[0] == '/':
22 docdir_stripped = docdir_stripped[1:]
23
24 d.setVar("docdir_stripped", docdir_stripped)
25}
26
27EXTRA_OECMAKE=" \
28 -DCMAKE_DOC_DIR=${docdir_stripped}/cmake-${CMAKE_MAJOR_VERSION} \
29 -DCMAKE_USE_SYSTEM_LIBRARIES=1 \
30 -DKWSYS_CHAR_IS_SIGNED=1 \
31 -DBUILD_CursesDialog=0 \
32 ${@base_contains('DISTRO_FEATURES', 'largefile', '-DKWSYS_LFS_WORKS=1', '-DKWSYS_LFS_DISABLE=1', d)} \
33"
34
35FILES_${PN} += "${datadir}/cmake-${CMAKE_MAJOR_VERSION}"
36FILES_${PN}-doc += "${docdir}/cmake-${CMAKE_MAJOR_VERSION}"
37
38BBCLASSEXTEND = "nativesdk"