summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake_2.8.10.2.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2013-05-20 19:20:39 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-24 14:14:42 +0100
commit24380e2be91e08fa5d33a81488c0a48e2576e51a (patch)
treeb2f030a139af603eedb9fdc2dabb6eb7866508f9 /meta/recipes-devtools/cmake/cmake_2.8.10.2.bb
parent26147b2aae329c896b3a6546bb079e8759c10184 (diff)
downloadpoky-24380e2be91e08fa5d33a81488c0a48e2576e51a.tar.gz
cmake: Update to 2.8.11
Rebased support-oe-qt4-tools-names as some of the changes where added in the upstream code. (From OE-Core rev: 13399264e987b698b120688dc5018adb3fa8522d) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake_2.8.10.2.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake_2.8.10.2.bb40
1 files changed, 0 insertions, 40 deletions
diff --git a/meta/recipes-devtools/cmake/cmake_2.8.10.2.bb b/meta/recipes-devtools/cmake/cmake_2.8.10.2.bb
deleted file mode 100644
index 65f75b4dca..0000000000
--- a/meta/recipes-devtools/cmake/cmake_2.8.10.2.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1require cmake.inc
2
3inherit cmake
4
5DEPENDS += "curl expat zlib libarchive ncurses"
6
7PR = "${INC_PR}.0"
8
9SRC_URI += "file://dont-run-cross-binaries.patch"
10
11SRC_URI[md5sum] = "097278785da7182ec0aea8769d06860c"
12SRC_URI[sha256sum] = "ce524fb39da06ee6d47534bbcec6e0b50422e18b62abc4781a4ba72ea2910eb1"
13
14# Strip ${prefix} from ${docdir}, set result into docdir_stripped
15python () {
16 prefix=d.getVar("prefix", True)
17 docdir=d.getVar("docdir", True)
18
19 if not docdir.startswith(prefix):
20 raise bb.build.FuncFailed('docdir must contain prefix as its prefix')
21
22 docdir_stripped = docdir[len(prefix):]
23 if len(docdir_stripped) > 0 and docdir_stripped[0] == '/':
24 docdir_stripped = docdir_stripped[1:]
25
26 d.setVar("docdir_stripped", docdir_stripped)
27}
28
29EXTRA_OECMAKE=" \
30 -DCMAKE_DOC_DIR=${docdir_stripped}/cmake-${CMAKE_MAJOR_VERSION} \
31 -DCMAKE_USE_SYSTEM_LIBRARIES=1 \
32 -DKWSYS_CHAR_IS_SIGNED=1 \
33 -DBUILD_CursesDialog=0 \
34 ${@base_contains('DISTRO_FEATURES', 'largefile', '-DKWSYS_LFS_WORKS=1', '-DKWSYS_LFS_DISABLE=1', d)} \
35"
36
37FILES_${PN} += "${datadir}/cmake-${CMAKE_MAJOR_VERSION}"
38FILES_${PN}-doc += "${docdir}/cmake-${CMAKE_MAJOR_VERSION}"
39
40BBCLASSEXTEND = "nativesdk"