diff options
author | Saul Wold <sgw@linux.intel.com> | 2012-11-16 19:59:20 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-12-03 14:32:47 +0000 |
commit | 7a697d070910dbe3289c001f0ea6e4059fd15f96 (patch) | |
tree | fcd15b7f6846f06acf7940b9b4ceef7d29fd5e3c /meta/recipes-devtools/cmake/cmake_2.8.10.1.bb | |
parent | b19ac46bca9b137b33a527e88e02451739bdb690 (diff) | |
download | poky-7a697d070910dbe3289c001f0ea6e4059fd15f96.tar.gz |
cmake: Update to 2.8.10.1
(From OE-Core rev: b109a6e33fc7748de65d1ff76528b302e7f92dd8)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake_2.8.10.1.bb')
-rw-r--r-- | meta/recipes-devtools/cmake/cmake_2.8.10.1.bb | 37 |
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake_2.8.10.1.bb b/meta/recipes-devtools/cmake/cmake_2.8.10.1.bb new file mode 100644 index 0000000000..9e1b802053 --- /dev/null +++ b/meta/recipes-devtools/cmake/cmake_2.8.10.1.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | require cmake.inc | ||
2 | |||
3 | inherit cmake | ||
4 | |||
5 | DEPENDS += "curl expat zlib libarchive ncurses" | ||
6 | |||
7 | PR = "${INC_PR}.0" | ||
8 | |||
9 | SRC_URI += "file://dont-run-cross-binaries.patch" | ||
10 | |||
11 | # Strip ${prefix} from ${docdir}, set result into docdir_stripped | ||
12 | python () { | ||
13 | prefix=d.getVar("prefix", True) | ||
14 | docdir=d.getVar("docdir", True) | ||
15 | |||
16 | if not docdir.startswith(prefix): | ||
17 | raise bb.build.FuncFailed('docdir must contain prefix as its prefix') | ||
18 | |||
19 | docdir_stripped = docdir[len(prefix):] | ||
20 | if len(docdir_stripped) > 0 and docdir_stripped[0] == '/': | ||
21 | docdir_stripped = docdir_stripped[1:] | ||
22 | |||
23 | d.setVar("docdir_stripped", docdir_stripped) | ||
24 | } | ||
25 | |||
26 | EXTRA_OECMAKE=" \ | ||
27 | -DCMAKE_DOC_DIR=${docdir_stripped}/cmake-${CMAKE_MAJOR_VERSION} \ | ||
28 | -DCMAKE_USE_SYSTEM_LIBRARIES=1 \ | ||
29 | -DKWSYS_CHAR_IS_SIGNED=1 \ | ||
30 | -DBUILD_CursesDialog=0 \ | ||
31 | ${@base_contains('DISTRO_FEATURES', 'largefile', '-DKWSYS_LFS_WORKS=1', '-DKWSYS_LFS_DISABLE=1', d)} \ | ||
32 | " | ||
33 | |||
34 | FILES_${PN} += "${datadir}/cmake-${CMAKE_MAJOR_VERSION}" | ||
35 | FILES_${PN}-doc += "${docdir}/cmake-${CMAKE_MAJOR_VERSION}" | ||
36 | |||
37 | BBCLASSEXTEND = "nativesdk" | ||