summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake-native_3.9.3.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2017-10-18 09:17:07 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-05 22:33:23 +0000
commit55fffefa89f1d81d34170723e8b7f6d2c5246e6b (patch)
tree7d534ba2ace41e5d7bba55a327a3be514e359185 /meta/recipes-devtools/cmake/cmake-native_3.9.3.bb
parent526d3e24b26a4914dee837a85b0897505e0ae7db (diff)
downloadpoky-55fffefa89f1d81d34170723e8b7f6d2c5246e6b.tar.gz
cmake: Upgrade to 3.9.3 release
This upgrades CMake from 3.8.2 to 3.9.3 release. The Copyright.txt file checksum change was due the addition of a new contributor on the contributors list. (From OE-Core rev: 053ad4bbcb72a1783c7928c2f86285c15472314f) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake-native_3.9.3.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.9.3.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.9.3.bb b/meta/recipes-devtools/cmake/cmake-native_3.9.3.bb
new file mode 100644
index 0000000000..e55e8b1cf6
--- /dev/null
+++ b/meta/recipes-devtools/cmake/cmake-native_3.9.3.bb
@@ -0,0 +1,38 @@
1require cmake.inc
2inherit native
3
4DEPENDS += "bzip2-replacement-native expat-native xz-native zlib-native curl-native"
5
6SRC_URI += "\
7 file://cmlibarchive-disable-ext2fs.patch \
8"
9
10B = "${WORKDIR}/build"
11do_configure[cleandirs] = "${B}"
12
13# Disable ccmake since we don't depend on ncurses
14CMAKE_EXTRACONF = "\
15 -DCMAKE_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
16 -DBUILD_CursesDialog=0 \
17 -DCMAKE_USE_SYSTEM_LIBRARIES=1 \
18 -DCMAKE_USE_SYSTEM_LIBRARY_JSONCPP=0 \
19 -DCMAKE_USE_SYSTEM_LIBRARY_LIBARCHIVE=0 \
20 -DCMAKE_USE_SYSTEM_LIBRARY_LIBUV=0 \
21 -DCMAKE_USE_SYSTEM_LIBRARY_LIBRHASH=0 \
22 -DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
23 -DHAVE_SYS_ACL_H=0 \
24"
25
26do_configure () {
27 ${S}/configure --verbose --prefix=${prefix} -- ${CMAKE_EXTRACONF}
28}
29
30do_compile() {
31 oe_runmake
32}
33
34do_install() {
35 oe_runmake 'DESTDIR=${D}' install
36}
37
38do_compile[progress] = "percent"